42" SHARP TV wont turn on

PoiisonArrowz

Estimable
May 12, 2015
2
0
4,510
0
Hey guys, I've had this SHARP TV for about 8 years now, probably less. It started to take 3-5 minute to turn on, I would press the power button and the red LED signal would disappear and then re appear in the next 3-5 minutes. The tv would turn on and we are able to watch tv. Now the tv does not turn on, even the red LED signal doesnt show even when the tv is plugged in.

I havnt let it try to turn on but i think it was almost an hour and the tv didnt turn on yet so i just unplugged it and put it away

I looked at the motherboard and i had read somewhere that a capacitor might be blown. I ran my finger over all the capacitors and 1 of them is popped out out the top and all the others were flat.

Could it be the power supply or the motherboard? I dont think i have a multimeter. But i will try to find one. (I have too many tools).

The model number on the tv is LC-42SB45U

Any help is greatly appreciated
 

PoiisonArrowz

Estimable
May 12, 2015
2
0
4,510
0
Thanks guys, I guess I wont be coming back here for answers lol. It was that single capacitor that made it die. your welcome poiison. thanks poiison :)
 

GYM17

Commendable
Jun 26, 2016
1
0
1,510
0
PA,

Did you ever figure out a solution to your problem? I have the same problem with an older model, LC-30HV4U.

Thanks
 
Thread starter Similar threads Forum Replies Date
AjB11 Streaming Video & TVs 3
Jamin215 Streaming Video & TVs 0
M Streaming Video & TVs 0
S Streaming Video & TVs 2
D Streaming Video & TVs 0
C Streaming Video & TVs 2
D Streaming Video & TVs 0
T Streaming Video & TVs 20
K Streaming Video & TVs 0
J Streaming Video & TVs 2
Browser6 Streaming Video & TVs 1
MukhlisM Streaming Video & TVs 1
G Streaming Video & TVs 1
T Streaming Video & TVs 1
J Streaming Video & TVs 1
W Streaming Video & TVs 5
B Streaming Video & TVs 1
S Streaming Video & TVs 1
E Streaming Video & TVs 1
M Streaming Video & TVs 2

ASK THE COMMUNITY