5.1 surround audio won't work properly?

sadab0

Estimable
Aug 31, 2014
20
0
4,560
0
All my speakers work (except for my center) but that's not what I'm concerned about ; my center speaker has actually been broken for some time now.

My problem is that the audio that comes out most of the time is stereo and my rear speakers and subwoofers don't play anything, The only time it works is when there's a 5.1 channel audio option on VLC and it defaults to that. Otherwise youtube, windows media player and vlc all don't play in surround sound it just defaults to stereo for some reason.
 

SkyBill40

Honorable
Oct 11, 2013
180
0
10,760
34
The likely reason none of the other sources play in surround is because they're recorded in stereo. Unless you use some kind of virtualization effect from your receiver, it'll probably remain stereo. The receiver knows what kind of signal it's being fed and won't play it accordingly through all chanbnels unless the source material says so.
 

ien2222

Distinguished
Mar 28, 2010
465
0
19,260
78
It sounds like it's working properly. If the content is stereo (which 99%+ of youtube and music libraries) it'll play as stereo.

Depending on the hardware you are using, you can get to it fill the rest of the speakers. On an AVR, set it to matrixed/prologic IIx/virtual surround/etc depending on the type of AVR. If this is a computer, in the audio settings there might be selection like the pervious stated, or something like "fill speakers" though you may not have an option to do so.
 

sadab0

Estimable
Aug 31, 2014
20
0
4,560
0

I don't use a receiver (the subwoofer has all the connections)
Every cable is connected to the subwoofer and it doesn't have any buttons like fast forward or anything like that it's just like regular computer speakers.

It worked fine on my last computer though with realtek HD audio manager.

 

sadab0

Estimable
Aug 31, 2014
20
0
4,560
0

I found the speaker fill option and it fixes the problem with VLC and Windows Media Player, unfortunately the subwoofer doesn't work if it's on. Youtube doesn't work altogether.

 

SkyBill40

Honorable
Oct 11, 2013
180
0
10,760
34
It's hard to say then if it worked previously and doesn't work now as you say. What I said about he content encoding in terms of the mix is true, however.

I used to run a 2.1 setup and it used the 3.5mm plug whereas my new one uses USB. Are you sure that the sub itself is still working correctly? Do you have any way to check it for proper functionality? Perhaps it's just time to get a new setup. Either way, good luck.
 

ien2222

Distinguished
Mar 28, 2010
465
0
19,260
78


Hmm...not sure why the sub would stop working when using "fill" or why youtube would stop altogether. What are you using for sound on the computer?
 

sadab0

Estimable
Aug 31, 2014
20
0
4,560
0
[strike]Ok, for reference I'll say that my center speaker started working again. [/strike] Nvm, my center speaker broke again -_-
@SkyBill40: I used the Windows Sound Manager to check if everything works properly and it does.
This is what I used to check: http://i.imgur.com/oEwOFNA.png

@ien2222: You misunderstood the Youtube part, I meant that Youtube doesn't work with my center, rear speakers and subwoofer. It just plays sound from my two front speakers. As for my sound, I'm using the "Altec Lansing VS3251" setup.

Also, can someone tell me how to direct the audio from my center speaker to my two front speakers? Since my center speaker is broken, a lot of the times when I'm watching 5.1 encoded audio all the voices and subtle sounds are meant to be played from the center so I end up missing it.
 

sadab0

Estimable
Aug 31, 2014
20
0
4,560
0

Guess I gotta go with the new system setup then.................How does 5.1 encoded audio sound on a stereo system?
Particularly these:http://www.cnet.com/news/build-your-own-desktop-stereo-for-under-70/ with a subwoofer
 

SkyBill40

Honorable
Oct 11, 2013
180
0
10,760
34
Dunno. I run a 2.1 setup and given the equipment I have (all Definitive Technology speakers), anything and everything sound awesome. Outside of that, I would expect the sound to be just fine since it should be automatically be downmixed to play on your setup.
 

ien2222

Distinguished
Mar 28, 2010
465
0
19,260
78
Sorry sadab0, computer went down last weekend and I just got it back up (mostly) today, didn't mean to duck out of the conversation like that.

Looks like Skybill covered your questions pretty good there.
 
Thread starter Similar threads Forum Replies Date
C Audio 1
Fal11n Audio 0
DakiMC Audio 1
B Audio 2
N Audio 6
A Audio 1
C Audio 2
C Audio 3
J Audio 7
A Audio 4
Kartunz Audio 6
R Audio 10
theking4mayor Audio 6
JackMateo123 Audio 1
B Audio 5
deusman Audio 1
2 Audio 3
A Audio 2
D Audio 4
J Audio 5
Similar threads
Question Does anyone have any suggestions on a good audio converters that r reasonably priced/any tips on how I should set up my home theatre?
Question HS45 Surround USB Conexant Audio Distortion.
Question 5.1 surround plays sound on all speakers instead of separately
Question How to get 5.1 Surround Sound from my HP Omen 875 PC to Receiver or Bose System from 1 3.5 Audio Out
Solved! New Laptop, Old AVR, need 5.1 surround sound
Solved! How to connect a Rockville EQ to a Yamaha RX-V567 Natural Sound AV Receiver/Amp with Polk Audio Surround speakers
Solved! 5.1 Surround Sound no audio playing on PC
Solved! 5.1 Surround Sound for my onboard 8-channel audio
Question How can i get TV audio out of my old surround sound system?
Solved! Assistance request with Windows/receiver/5.1
Question 7.1 surround headset volume low when driver is installed
Solved! Connecting an old surround sound 5.1 system to a new dvd player
Question Realtek Audio won't play stereo, only surround
Question Games with surround sound are significantly quieter than those without.
Question Subwoofer on 2.1 speaker system not working(Logitech Z623) when connected via aux
Question How does one hook up 5.1 surround sound ? (Logitech Z607)
Question Connect TV to Surround sound when TV has no audio outputs at all
Question All I get is static(white noise) when I use optical on my av receiver
Question Connecting soundbar and audio receiver with surround sound to tv
5.1 surround not properly channelized with optical audio i/p

ASK THE COMMUNITY