Question 55" TCL TV - No picture, backlight/sound work, T-Con board was replaced

Sep 10, 2021
2
0
10
0
I was given a 55" 2017 TCL Roku TV that has an issue of no picture, but the backlights and audio are in full operation. I did some digging and narrowed it down to a possibly bad T-Con board, I replaced it today with a unit I got off of Ebay but the issue is still there. I'm not good with electronic testing (multimeter, soldering, etc.) so I would appreciate any insight on the likely cause. Screen appears undamaged and the remote can still switch around settings (I've tried a hard reset). I assume it could be the video or power boards, but I also had a theory on it being the ribbon cables, as my replacement board came without new ones. I planned on fixing it and giving it to my sister, but now I'm stuck with a TV that I already sunk $24 into, so now I have to fix it. I know TCL's are notorious for issues, being mass manufactured in China for Walmart sales, but I don't want to sink much more money into this project if its just not worth it. This is the second TV I've tried to repair, but failed. What are your thoughts or opinions on this? I'd appreciate any feedback, thanks!

Model #: 55us57-wtlaa

T-Con #: ST5461D04-1-C-7









 
Last edited:
Thread starter Similar threads Forum Replies Date
Y TVs 0
M TVs 1
P TVs 1
K TVs 0
V TVs 0
Rigney TVs 0
S TVs 0
L TVs 0
K TVs 0
uzxi TVs 0
M TVs 0
T TVs 0
M TVs 0
anontvuser23 TVs 1
R TVs 1
M TVs 0
btjones TVs 0
L TVs 1
I TVs 2
S TVs 1

ASK THE COMMUNITY