AMD 7970M slower (fps) than basic intel HD 4000

ijakez

Commendable
Jun 10, 2016
1
0
1,510
0
I have a pre-built P170EM laptop. Whenever I try to play any game using the dedicated graphics card, although the video is a lot better quality, the FPS is lower (abyssmal; 20-30 on lowest settings for games that aren't too intensive). I've updated BIOS and uninstalled/reinstalled drivers for both graphics cards, but I can't seem to diagnose or fix the issue properly. Any help would be great!
 
Hi,

Please do try doing a clean install of the graphics driver that may do the trick.
- Go to Device Manager and uninstall the AMD graphics driver.
- Next is to open Programs and Features then uninstall anything related to AMD.
- Once done, download and install the latest driver.
- Here's the link: http://support.amd.com/en-us/download
- Reboot the PC once the latest driver has been installed.
- After the reboot do set AMD to High Performance then test it again.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
F Laptop Tech Support 2
T Laptop Tech Support 6
N Laptop Tech Support 1
K Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 8
Y Laptop Tech Support 5
Thepigdude Laptop Tech Support 1
W Laptop Tech Support 2
Z Laptop Tech Support 5
A Laptop Tech Support 5
S Laptop Tech Support 1
mclovits Laptop Tech Support 13
Obakemono Laptop Tech Support 2
lazyboy947 Laptop Tech Support 6
M Laptop Tech Support 4
F Laptop Tech Support 2
F Laptop Tech Support 2
N Laptop Tech Support 3

ASK THE COMMUNITY