asus g75vw no sound and sudden no internet connection either wifi or via ethernet cable, other xps laptop works fine

dimitri3d

Estimable
Dec 10, 2015
3
0
4,510
0
Power cuts off and turns off the G75VW but not often. this happens once every 2 months. I can live with it, but save my work all the time.

I need help. Somehow, I cannot connect to the internet via wifi or via ethernet cable and my speaker image on the desktop has a big red X on it. What is going on. Anyone knows? I must have gotten a virus. I will do a clean install in 2 months, but can someone tell me how to get it to connect to the internet and get the sound working. I'm not ready for the clean install yet, since I need to back up TB of data to external drives.

does anyone know what is the sound card model for the g75vw so i can download the drivers?
Thanks guys
Dimitris

<,Email address removed by moderator. Please communicate in threads or via PM. Never post your email address.>>
 
Hi,

Do try to uninstall/reinstall the devices that are not working.
- Go to Device Manager and uninstall the Network Adapters (both LAN and wireless).
- Reboot your laptop and that should reinstall the driver automatically after the reboot.
- If that will not work do download and install the drivers from Asus Support site.
- https://www.asus.com/support/Download/3/388/0/1/gkyI9iViQxXxueTd/30/
- Just change the OS base on what you have on your laptop and it will give you all the drivers you need for your laptop.
- Once those drivers has been installed reboot your laptop then test it again.
- If all these will not work your last resort would be to do the factory reset.
 

dimitri3d

Estimable
Dec 10, 2015
3
0
4,510
0


 

dimitri3d

Estimable
Dec 10, 2015
3
0
4,510
0
Thank you. I went in to the ASUS website you told me 3 days ago. I downloaded ALL the drivers about 100 of them. You see there are 5 drivers under BIOS, 3 drivers under AUDIO, 4 drivers under VGA, 4 drivers under wireless.

Which one do I install? Look at the dates created and choose the most recent one? Also I do not know what to do about the red X over my speakers. I have no sound and no internet connection.
I assume from what I read that the ASUS G75VW has a Realtek ALC1200 HD Audio see link
http://forums.guru3d.com/showthread.php?t=365611

I will replace the drives with SSD drives in February and get rid of Win 8.1 Pro and install Win 7 Ultimate x64 but I need to have internet and sound on the G75VW till February. Any more suggestions? Please let me know. I downloaded all the G75VW drivers and tools both for win 8.1 and win 7 x64 so I have them. Also downloaded several reseases of the Realtek Audio Drivers, the last one is version 2.79 x64 for win 7, 8, 8.1 and 10 plus AtherosAR948WB EG WiFi and LAN Atheros Z2107 for win 8.1 x64. Please give me advice, regarding the ASUS website drivers and the multiple versions of each category (bios, audio, wireless....etc).
Thank you,
Dimitris
email: dimitri3d@aol.com
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 3
K Laptop Tech Support 1
N Laptop Tech Support 1
RocketFlamingo Laptop Tech Support 1
K Laptop Tech Support 2
Z Laptop Tech Support 9
Y Laptop Tech Support 2
someguynamedmatt Laptop Tech Support 2
W Laptop Tech Support 7
C Laptop Tech Support 1
M Laptop Tech Support 2
F Laptop Tech Support 2
I Laptop Tech Support 3
E Laptop Tech Support 1
Z Laptop Tech Support 2
G Laptop Tech Support 6
epsilon1475 Laptop Tech Support 3
K Laptop Tech Support 2
D Laptop Tech Support 2
L Laptop Tech Support 7

ASK THE COMMUNITY