Asus R510DP-FH11 won't start


Jun 20, 2016
I have an Asus r510dp-fh11 laptop. It was working fine up until yesterday, when it died spontaneously while I was doing some gaming. It was a hot day, so I figured maybe overheating was the cause, but after letting it sit for a while, it would not come back on. When the power button is pressed, all the indicator lights come on and the fan starts for about 1 second, then it all dies. The same thing happens multiple times in a row if I keep trying the power button. I've tried removing the battery, unplugging, and holding the power button for 30 seconds; replacing the CMOS battery; taking out and replacing the ram. Nothing so far has made any difference. Any help would be greatly appreciated.

You've pretty much done most of the possible troubleshooting steps but here are some more that may help.
- First is to do a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again with the battery and charger.
- Next test to try would be to remove the battery again and connect just the AC adapter and see if it will boot up or not.
- If the laptop will still not boot up with just the AC adapter connected do try a different AC adapter that has the same voltage.
- Do also reseat the RAM's, remove them all for couple of seconds then put them back in making sure everything is seated properly.
- Lastly, do also try connecting an external monitor and see if you'll get any display from it.
- If all these will not work the problem lies in the motherboard.