ASUS ROG GL553VE Plug in not charging Problem

Feb 19, 2018
2
0
10
0
CAN ANYONE HELP ME ?? MY ASUS ROG GL553VE PLUG IN BUT NOT CHARGING. IM TRYING THE METHOD OF 15SEC. PUSH POWER BUTTON AND PLUG IN, AND ITS WORKING BUT AFTER FEW MINUTES IT WILL NOT CHARGE AGAIN. ITS ALWAYS BLINKING IF ITS NOT CHARGING WHILE PLUG IN. I DONT KNOW WHAT HAPPEN. BUT ANYONE CAN HELP ME THIS ?? THIS IS 6MONTHS OLD BUT DEFINITELY IM JUST USING THIS MAXIMUM OF 4HRS A DAY AND ITS ONLY WATCHING A MOVIES BECAUSE I DONT HAVE GAMES YET SO PLEASE. I HAVE A 4 DAYS TO OPEN AN INTERNET BECAUSE OUR INTERNET IS LIMIT AFTEE 4DAYS WE GO BACK SAIL AGAIN. PLEASE AND THANK YOU IN ADVANCE!!
 

camrenperry7704

Prominent
Nov 22, 2017
1
0
520
1
I have the same problem with multiple new laptops, and it seems like a software glitch. Try draining the battery to 94% and then plug it in and it should say it's charging.
 

camrenperry7704

Prominent
Nov 22, 2017
1
0
520
1
I have the same problem with multiple new laptops, and it seems like a software glitch. Try draining the battery to 94% and then plug it in and it should say it's charging.
 
Thread starter Similar threads Forum Replies Date
SZilveti Laptop General Discussion 2
F Laptop General Discussion 5
J Laptop General Discussion 4
Realghost45 Laptop General Discussion 1
alyrezz Laptop General Discussion 1
D Laptop General Discussion 4
DeltaPsy Laptop General Discussion 1
T Laptop General Discussion 0
V Laptop General Discussion 2
M Laptop General Discussion 2
Collins59@ Laptop General Discussion 1
F Laptop General Discussion 0
B Laptop General Discussion 1
M Laptop General Discussion 1
tardycoder5 Laptop General Discussion 1
Ruhan GM Laptop General Discussion 1
R Laptop General Discussion 1
P Laptop General Discussion 1
NicroCide Laptop General Discussion 1
G Laptop General Discussion 4

ASK THE COMMUNITY