Asus T100 driver problems

reubenno

Honorable
Sep 2, 2012
16
0
10,570
1
Hello,
I (stupidly) decided to try and upgrade an Asus T100 laptop to Windows 10. The install failed and I was forced to reinstall Windows 8.1 instead as a fresh Windows install. I have managed to get most of the drivers installed however I cannot get sound to work, and more notably the touch screen is not working. I have tried drivers for both from the Asus website but nothing is working.

For the audio I am told that there is no audio devices found, installing the Realtek drivers do not work (I have tried this multiple times).

I don't have a HID Touch Screen device in the device manager and I can't find the drivers for the laptop online.

Has anybody had the same problem as I am losing hope, I am going back to university on Monday and I would really like to have it fixed by then as my father relies on the T100 daily.

Thanks.
 

reubenno

Honorable
Sep 2, 2012
16
0
10,570
1


Thanks for the reply, I managed to fix the problem by using a hotfix on the Asus website :)

 
Hi,

Please do try these troubleshooting steps that may help.
- First is to uninstall the Realtek driver already installed in Device Manager.
- Once done, download and install the latest driver from ASUS Support site.
- Here's the link: http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/Audio/Audio_Realtek_Win81_32_VER6296004087.zip?_ga=1.57588648.305422646.1455979617
- Reboot after installing the latest driver and test it again.
- About the Touch screen problem, just do the same uninstall/reinstall the driver.
- Go to Device Manager and uninstall the graphics driver.
- Next is to open Programs and Features and uninstall anything related to the graphics card.
- Once done, download and install the latest driver from the manufacturer site of the graphics card.
- Reboot the laptop once the latest driver has been installed then test it again.

Hopefully this steps will help. :)
 

reubenno

Honorable
Sep 2, 2012
16
0
10,570
1


Thanks for the reply, I managed to fix the problem by using a hotfix on the Asus website :)

 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 7
P Laptop Tech Support 0
T Laptop Tech Support 1
sam_voerman Laptop Tech Support 1
reactive707 Laptop Tech Support 3
raintop Laptop Tech Support 2
D Laptop Tech Support 3
T Laptop Tech Support 1
G Laptop Tech Support 3
ugapeyton Laptop Tech Support 1
Swartzy Laptop Tech Support 1
J Laptop Tech Support 3
G Laptop Tech Support 4
B Laptop Tech Support 1
N Laptop Tech Support 2
N Laptop Tech Support 1
L Laptop Tech Support 1
K Laptop Tech Support 3
Z Laptop Tech Support 2
A Laptop Tech Support 1

ASK THE COMMUNITY