• Check out all the best Amazon Prime Day deals 2021 here!

Solved! Asus VivoBook x512 hdd installation

Sep 10, 2020
1
0
10
0
I installed a new 1 TB HDD on vivobook x512. But laptop is not starting. As I removed hdd cable it started. Please help.
 

AlHuneke

Notable
Jul 7, 2020
604
72
890
74
I hope you are not plugging or unplugging the HDD with the power on. Good way to damage things! I also hope you are using ESD precautions (https://www.gamersnexus.net/guides/920-electrostatic-discharge-prevent-esd). The problem can't be diagnosed without more information. Can you use a SATA to USB cable to try to plug the drive into a USB port and see if it can be accessed. If it is brand new, it will need to be formatted but should still show up on Explorer.
 

AlHuneke

Notable
Jul 7, 2020
604
72
890
74
I hope you are not plugging or unplugging the HDD with the power on. Good way to damage things! I also hope you are using ESD precautions (https://www.gamersnexus.net/guides/920-electrostatic-discharge-prevent-esd). The problem can't be diagnosed without more information. Can you use a SATA to USB cable to try to plug the drive into a USB port and see if it can be accessed. If it is brand new, it will need to be formatted but should still show up on Explorer.
 
Thread starter Similar threads Forum Replies Date
L Laptop Tech Support 1
A Laptop Tech Support 0
Ravshan Laptop Tech Support 2
A Laptop Tech Support 0
Jcano2605 Laptop Tech Support 2
Venura_Ganuka Laptop Tech Support 5
Arnavv24 Laptop Tech Support 0
Phoenix1217 Laptop Tech Support 0
1nf1n17y Laptop Tech Support 1
J Laptop Tech Support 0
C Laptop Tech Support 1
Shock31 Laptop Tech Support 0
Bboyxan Laptop Tech Support 1
Karl Alexander Laptop Tech Support 3
Fercho0316 Laptop Tech Support 1
ellenleigh122627 Laptop Tech Support 1
rudotelyne96 Laptop Tech Support 0
sid_nir Laptop Tech Support 3
K Laptop Tech Support 0
S Laptop Tech Support 2

ASK THE COMMUNITY