GreyCatz

Admirable
Increasing RAM capacity will primarily boost multi-tasking. While more RAM will also help with gaming, I doubt it will improve the FPS count to any noticeable degree in this particular case. If anything, the game will probably run with less stutter, but I can't promise any FPS improvement.

If you can upgrade to 8GBs of RAM, you should definitely do so - the laptop will run more smoothly and you can use more applications simultaneously.
 

GreyCatz

Admirable
Here are some different options:

1. Windows Control Panel>Hardware & sound>nVidia Control Panel.

2. Windows Control Panel>Hardware & sound>Device Manager. Make sure your nVidia graphics card is enabled.

3. Access the BIOS menu and locate the Advanced tab. Under Video you can choose different setups, but this is for experienced users only.
 

thesmartgoat

Prominent
Aug 27, 2017
7
0
510
0


1 tried didnt worked
2 aswell its enabled
3 there is no "video" in bios under advanced tab for me ?
 

GreyCatz

Admirable
Re 1: In the nVidia Control Panel>Manage 3D Settings, select the Global Settings tab. Scroll down and click 'OpenGL rendering GPU'. You should now be able to choose between 'Auto-select' or 'GeForce 930 MX'. Also, go to Set PhysX Configuration and click 'Processor'. This should open a drop-down list with your graphics engines.

You can also click Desktop on the menu bar and select 'Display GPU Activity Icon in Notification Area'. Now you can see how much the nVidia GPU is used in the bottom of the screen.

Re 2: If your nVidia card is enabled, it should engage whenever the need arises. Update the driver. Also, you could try and disable it and restart the computer. Then enable it again.

Re 3: Your ASUS BIOS menu is probably different from those in my computers. Browse around and see if you can find any feature that allows you to select graphics engines. It may show options such as Auto, IGP, PCIx or something similar. I don't know what your BIOS looks like, but I'm pretty sure there is such a feature somewhere. When you find it, make sure it's set to 'Auto'. Again, this is tricky stuff so you should only change the settings if it says anything other than Auto.
 

thesmartgoat

Prominent
Aug 27, 2017
7
0
510
0


searched the whole the bios... only thing available fro me in "graphics configuration" is "dvmt preallocated" nothing else there besides this
 

GreyCatz

Admirable
At this point I'm going to ask for some detailed specs about your particular ASUS Vivobook. So far, I've used this ASUS spec sheet as reference:

https://www.asus.com/Laptops/VivoBook-X456UR/specifications/

What CPU does your Vivobook use?
 

GreyCatz

Admirable
UPDATE:

I just found out that the Vivobook ships with nVidia's Optimus technology. This means that the GPU manages the graphics workload automatically. Therefore, you can't manually select one graphics engine over the other. In other words, the GPU adapts to your usage, and you are not supposed to interfere with this. And going by our correspondence, it isn't possible anyway.

I'm sorry for this oversight, but that's your situation with this ASUS. The good news is that the Optimus technology should give you better battery life and better overall performance.
 

thesmartgoat

Prominent
Aug 27, 2017
7
0
510
0


thanks that solves...maybe unprading ram to 8gb from 4gb would solve fps in gaming ?
 

GreyCatz

Admirable
Increasing RAM capacity will primarily boost multi-tasking. While more RAM will also help with gaming, I doubt it will improve the FPS count to any noticeable degree in this particular case. If anything, the game will probably run with less stutter, but I can't promise any FPS improvement.

If you can upgrade to 8GBs of RAM, you should definitely do so - the laptop will run more smoothly and you can use more applications simultaneously.
 

thesmartgoat

Prominent
Aug 27, 2017
7
0
510
0


thanks much appreciate :)
 

ASK THE COMMUNITY