Question Asus X541U laptop wont powering on on Battery, its working with AC charger

Feb 25, 2019
4
0
10
0
hello guys,

i having Asus X541U Laptop, i3 7th Generation and 4GB of RAM.
i decided to upgrade its memory from 4gb to 8gb and i put new 8gb memory in it. and i ressamble the laptop.
now when i powering ON my laptop it wont powering up. I tried many times but it wont worked. then i put AC charger in it and tried to power up and bingo its working, now problem is my battery is almost 92% charged still it wont power up with batyery, if i plugged the AC charger it working fine. what should i do to fix it and back to working in battery mode again.?
 
Feb 25, 2019
4
0
10
0
And did you try putting back the old RAM to see if it worked in battery mode with that?
yes i tried that too.
i also try by reset BIOS
and the other trick as bellow:
Tricks "(remove charger hold power button 15-20 seconds then plug charger then power on and then power off and remove charger then re powering on without charger)"

but none of these works ??

please help me ?
 
Well that last one actually requires that you also remove the battery when you do it, and it should be at least 30 seconds, not lower.

Have you considered that the battery needs replacing? I mean I get the timing of it and all, but if it works completely fine when on the charger, but not when on the battery, then that would be my next step, replacing the battery.
 
Feb 25, 2019
4
0
10
0
Well that last one actually requires that you also remove the battery when you do it, and it should be at least 30 seconds, not lower.

Have you considered that the battery needs replacing? I mean I get the timing of it and all, but if it works completely fine when on the charger, but not when on the battery, then that would be my next step, replacing the battery.
no need to replace battery as because my laptop already giving me a nice 3-4 hour battery backup just right before i replace RAM.

that solution of pressing power button for 30 second without battery i try and tell the result.
 
Feb 25, 2019
4
0
10
0
i tried to replace original ram back and do that power button hold things more then 30 seconda and also with battery and without battery still the issue remain same and one more thing i update my bios firmare also still the situation remains same. any possible solution or idea? ?

i check and note one thing when i remove battery and power on lappy with AC power source it display "no battery detected" in windows 10, but when i plug the battery and power on lappy with AC supplier is show 'battery is charging" and percentage is around 95%. so i guess my battery is not damaged but aome software issues there ?
 
While the % of the battery, and the ability of the battery to charge, may make it seem fine, that doesn't mean it is.

A battery that is going bad can still charge, for a while at least, and still run the device for shorter and shorter periods. However, if it won't start up when the battery is the only power supply, then the battery isn't working correctly.

It takes a low more power to start up the device than it does to just run it.
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 0
P Laptop Tech Support 0
G Laptop Tech Support 0
Ashley Muller Laptop Tech Support 3
E Laptop Tech Support 1
OsamaHad Laptop Tech Support 1
newuser@123 Laptop Tech Support 1
TheKiwi01 Laptop Tech Support 3
M Laptop Tech Support 3
S Laptop Tech Support 1
Y Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 1
D Laptop Tech Support 1
J Laptop Tech Support 1
I Laptop Tech Support 1
T Laptop Tech Support 1
S Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS