Audio/Mic issues in games.


Apr 5, 2014
So! I just bought the Logitech G430 headset. I was using just some 2.1 headphones for audio and a LifeCam HD-5000 for a mic, the headphones were plugged into the audio jack on my Logitech LS21.
Now I have the Logitech USB plugged into a CHA USB. It works.
I start up Teamspeak and the mic is transmitting and headset's receiving.
I then launch a game (BF2: Project Reality) Then the audio keeps switching from my speakers to my headset. I bring up the logitech UI and Devices (from control panel) it's a detection issue. It can't find it then it can, etc.
I left Teamspeak and unplugged speakers and LifeCam and (I think) I relaunched the game. Audio worked, but my mic wouldn't transmit (I think this was just an issue with Mumble).
ALSO!! Sometimes it works right through the loading screen, but as soon as the game loads and I'm actually in game. Audio issues! :/ When I close the game it's back to normal.
What's going on? Why isn't the the headset being detected always?

Edit: tried starting up Planetside 2 under similar conditions, audio was working for ~10 minutes then lost output from game.


Apr 5, 2014
I've isolated the problem, it's mumble.
I ran through the settings and was able to fix it while there weren't multiple programs conflicting.

[EDIT] I started it up again, problem is still persisting.
w/e delete this thread.
Thread starter Similar threads Forum Replies Date
B Audio 0
V Audio 1
R Audio 0
VanAkard Audio 5
M Audio 0
H Audio 0
Y Audio 3
S Audio 0
Randall The 2nd Audio 0
Redeemedshelby Audio 1
Blackened Hat Audio 1
E Audio 1
T Audio 8
L Audio 6
E Audio 13
H Audio 13
N Audio 1
R Audio 1
M Audio 2
C Audio 1