Audio plays through Headphones, but doesn't play through Speakers Windows 10

Ryu Draco

Commendable
Jul 24, 2016
6
0
1,510
0
Today I turned my laptop on MSI PE60 2QD 2015 and I wanted to listen to some spotify through the speakers. When I pressed play no sound came out. When i plugged in my headphones it worked though. Usually when i plug in my headphones i get a message saying to choose from the Speakers Headphones or both and that didn't happen this time. What do i do?
 
It sounds like at some point your headphones became the primary sound location. Even if you didn't mean that to happen. You will need to go into "Control Panel" then "Sound" and choose the device you want to set as the default. Which in your case would be the speakers.
 

Ryu Draco

Commendable
Jul 24, 2016
6
0
1,510
0


See here's the thing, i can't look. https://gyazo.com/07613c6922f5be4972d6c5633fe36981 That's a link to gyazo (an image sharing platform) if you don't trust it basically in the Sound option under "Playback" it only gives me "Speakers" and
"Realtek Digital Output" which is grayed out and labeled as not plugged in.
 

Ryu Draco

Commendable
Jul 24, 2016
6
0
1,510
0


Yes. And when they are not plugged in.

I've deleted the driver and reinstalled the High Definition Driver (the one that Windows Provides Instead of Realtek.) I can use the speakers and the headphones, but to switch i need to go to the sound software and switch the default sound stuff which isn't what I've had to do before. Before a popup came up asking me whether to use laptop headphones or both. Also a Red Light is coming out of the headphone jack, indicating that the digital audio out is enabled. So once again i update to the realtek driver and my speakers are broken again help!
 

Ryu Draco

Commendable
Jul 24, 2016
6
0
1,510
0


I have another laptop that i bought today for school (this one is my powerhouse workstation) and that laptop only has "speakers as well" but nothing else is grayed out like here. hmmmmm
 

Ryu Draco

Commendable
Jul 24, 2016
6
0
1,510
0


It's enabled.
 

Ryu Draco

Commendable
Jul 24, 2016
6
0
1,510
0


By the way do you think resetting the device completely (factory reset) would help?
 
If it is somehow a software problem that is possible, but before going that far I would try a few other things. If you know about how long ago it started to be a problem, you could restore the system to an earlier restore point and see if that resolves it.
 

ciber

Estimable
Mar 30, 2015
2
0
4,510
0
Hey, i had the same problem, and i formated the pc thinking it would solve the problem, and now, i don't have a restore point. i did everything and yet no luck :(
What can i possible do to solve this? i've allready clean install drivers and that didn't solve the problem, please help, this is driving me insane!!
 
Nov 27, 2018
1
0
10
0
Hey, I've been having this same issue for the past months and after searching high and low without any success what I just now did was uninstalling realtek audio driver entirely, after that everything went back to normal. Hope this can be of use to you guys
 
Jan 9, 2019
1
0
10
0
If you hear some of the sounds on the speakers but not all of them, possibly its configured for 5.1 surround. Try "Stereo" instead! On Windows 10, Right click on the speaker icon, select "Sounds", on the "Playback" tab select the speakers and press "Configure" button.
 
Jan 12, 2019
1
0
10
0
this is happening to me too but idk how to solve- i tried like everything - i loaded again default settings in BIOS but stil not sound from my laptop - only with headset - if anyone has a solution please guys i need help as soon as possible - Facebook - klevi alushi , discord - k3nt2852 , steam k3nt89.al - PLS help me guys