Automatic screen dimming (MSI Ghost Pro 002 6QE)

rorytheherb

Estimable
Feb 11, 2014
3
0
4,510
0
Hi all,
System:
MSI Ghost Pro GS60 6QE
nVIDIA GTX970M driver 359.06 (2nd latest driver; latest causes BSOD on this system)
Intel HD Graphics 530 (latest driver). In Intel Graphics Control Panel, Power Settings, Extended Battery Life for Gaming is Disabled.
Windows 10.0.10586

In Windows, Power settings are set to High Performance for both 'plugged in' and 'on battery'. In Advanced Power Settings the High Performance power plan, in the display section, adaptive brightness is already disabled.

In spite of this, the display slowly dims to ~5% brightness all by itself over the course of ~1 hr, either plugged in or on battery.

I saw a few people with similar problems online who solved this by adjusting settings in Windows, but I've changed all the relevant settings I can find. Anyone know how to fix this?

thanks
Rory
 
Hi,

First please do try to do a clean install of the graphics card driver.
- Go to Device Manager and uninstall the graphics card driver.
- Check Programs and Features as well and check if there are anything related to your graphics card.
- Download and install the latest graphics driver from NVIDIA support site.
- Here's the link: nvidia.com/download/index.aspx
- Reboot your laptop once the latest driver has been installed.

If these doesn't work please do try these troubleshooting steps from Lenovo about changing some Options that may help.

https://forums.lenovo.com/t5/ThinkPad-S-Series-ThinkPad-Yoga/Random-changes-in-screen-brightness-every-few-minutes-in-Windows/ta-p/915291
 

rorytheherb

Estimable
Feb 11, 2014
3
0
4,510
0
The graphics card drivers are both clean installs. As I mentioned, it is not the latest nVIDIA driver, since the latest causes reproducible BSODs (upon opening Photoshop, and upon entering Intel Graphics Control Panel Settings). The screen dimming also occurred with the latest nVIDIA driver.

I read the Lenovo page advice. What I noticed is that in my Power Options\Edit Plan Settings, the 'Dim the Display' options are missing. I only have options for Turn off, sleep, and plan brightness.

Another thing is that in my Intel Graphics Control Panel Power settings, Extended Battery Life for Gaming is the only thing there to adjust. I think I read in another forum thread that there was an option for dimming the screen here.

Seems like this is probably related to my problem. Maybe a BIOS setting is preventing Windows from accessing it??
 
Thread starter Similar threads Forum Replies Date
Loureyna Laptop Tech Support 3
S Laptop Tech Support 1
D Laptop Tech Support 3
M Laptop Tech Support 2
C Laptop Tech Support 0
F Laptop Tech Support 1
J Laptop Tech Support 1
H Laptop Tech Support 1
H Laptop Tech Support 1
H Laptop Tech Support 1
D Laptop Tech Support 1
D Laptop Tech Support 3
C Laptop Tech Support 1
T Laptop Tech Support 2
F Laptop Tech Support 1
J Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 1
D Laptop Tech Support 1
A Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY