Basically no Bass coming out of my speakers. Help please!

TheHammerOfficial

Commendable
Apr 29, 2016
12
0
1,560
0
Hey everybody. I have finally succeeded in setting up my audio system, but my speakers aren't pounding...even at max volume and Bass Boosted songs from Youtube, I am barely getting anything. So here's my setup:

Receiver: Sony STR-K900
Speakers: 2x Technics SB-A26's

I assume I have the settings correct on the receiver itself. I have the Bass cranked as high as it will go. (+6) The receiver is set for L + R and that's it, only 2 speakers. Any audio tech's out there, please for the love of god, save all this equipment from total annihilation...I am literally about to obliterate all of it with my sledgehammer. Thanks in advance!
 
Selecting the receiver to operate in stereo will disable the center and rears but won't turn off the subwoofer since if you had one you would probably want it working in stereo and surround modes. The receiver doesn't auto detect if there is a sub connected unless it has an auto set up mode that uses a microphone that came with the receiver.
You can set the receiver up from the amp set up button on the remote. Couldn't find the owners manual but here is a link to the service manual.
https://www.manualowl.com/p/Sony/STR-K900/Manual/57991
Set the fronts to large, center sub and rears to none.
 
Sounds like your surround sound receiver is set up for a subwoofer (which you don't have) so it takes away all the bass from the front left/right speaker outputs and sends it to the nonexistent sub. Go into the speaker set up menu and set the front speakers to large and sub, center, and surrounds to none.
 

Jim90

Honorable
Feb 3, 2013
19
0
10,570
1
If the feed into the receiver if from a PC (assuming since this is tom's) then try bypassing the PC and connecting a few other devices e.g. portable mp3 player, cd player, etc.
If you get the same problem (bass light) then the issue is with the receiver/speaker setup. In this case recheck the receiver/speaker setup - making sure factory default settings are restored, if applicable.
If on the other hand, it's only the PC that results in a bass light sound then load the sound application that comes with your motherboard/pc installation. Check all settings here and restore default settings if possible. Make sure that the correct speaker set up is selected in the software to match your speaker set up. Recheck the output jack connections you have used - don't connect to a non existent speaker (as per your setup).
 

TheHammerOfficial

Commendable
Apr 29, 2016
12
0
1,560
0


Unfortunately, (as far as I know), I have done this. Basically it's set for L + R and that's it according to the picture it is giving me on the receiver itself. I will go and see if I am doing it correctly and will update if something changes!

Update 1: I have no idea how to disable the sub woofer LOL.

Update 2: There is no option for me to disable the subwoofer. On the front display however, it is giving me the L+R and SW icons all lit up, but I don't have a subwoofer hooked up at all.
 
Selecting the receiver to operate in stereo will disable the center and rears but won't turn off the subwoofer since if you had one you would probably want it working in stereo and surround modes. The receiver doesn't auto detect if there is a sub connected unless it has an auto set up mode that uses a microphone that came with the receiver.
You can set the receiver up from the amp set up button on the remote. Couldn't find the owners manual but here is a link to the service manual.
https://www.manualowl.com/p/Sony/STR-K900/Manual/57991
Set the fronts to large, center sub and rears to none.
 

Will_28

Commendable
May 22, 2016
1
0
1,510
0
I'm having the same issue with the same receiver. I do have a subwoofer but I want the bass to come out of my speakers as well, not just the subwoofer. Been trying for hours to figure this out but no luck. Any advice would be greatly appreciated.

For the guy above me, there is new "large/small" setting for the speakers with this amp
 
Thread starter Similar threads Forum Replies Date
J Audio 1
Randall The 2nd Audio 0
M Audio 2
A Audio 1
S Audio 4
M Audio 2
T Audio 2
D Audio 1
A Audio 1
Z Audio 3
R Audio 12
A Audio 4
F Audio 2
B Audio 5
G Audio 1
szury Audio 6
C Audio 5
M Audio 5
axels01 Audio 6
S Audio 5

ASK THE COMMUNITY