Question Blue Yeti stopped working suddenly.

Apr 17, 2019
1
0
10
0
The problem started on March 22nd and since then I still haven’t fixed it. (Then again, I had no reason to use the microphone for a good couple weeks before I discovered the problem so it could’ve occurred beforehand).

The issue is that I cannot get any sound to be picked up from the mic.
The device still receives power, but on no circumstance is sound picked up by my computer. Even the playback settings where I can listen to myself can’t seem to pick up anything. The device isn’t muted at all, it sits with the shiny red button constantly on.

I’ve tried:
  1. Unplugging the USB
  2. Uninstalling/ reinstalling the device
  3. Making sure the privacy settings were fine
  4. Setting the device to be default
  5. Restarting my computer
  6. Running malware tests
  7. Updating my drivers
  8. Updating my PC
I am not a tech guru but I do not think audio input devices are completely corrupt on my PC since I have a Bluetooth headset that can still pick up and record audio. (This could be completely different, like I said, not a tech guru).

I initially thought the mic was just old and had lived out its time (I got it nearly 5 years ago), HOWEVER, I plugged it into a lap top and it seemed to pick up sound just fine.

I seriously have zero idea how it stopped working. It could very well be the start of my PC’s demise since I also got it 5-6 years ago but who knows.

If anyone has any solutions please let me know.
(I am on Windows 8.1 btw)
 
Thread starter Similar threads Forum Replies Date
O Audio 0
J Audio 1
S Audio 0
T Audio 1
J Audio 0
B Audio 0
J Audio 2
D Audio 0
J Audio 0
D Audio 0
L Audio 1
S Audio 1
O Audio 1
S Audio 2
K Audio 1
J Audio 3
J Audio 1
H Audio 1
P Audio 8
ENJOIPANDABURGERS Audio 1

Similar threads


ASK THE COMMUNITY