Bose speaker problem with having a humming/buzzing sound when turned on.

Blake Burkhart

Estimable
Sep 15, 2014
1
0
4,510
0
I bought a pair of Bose companion 2 series 3 speakers. I plug them into my computer and it hums/buzzes when i have it turned on. I plug it into my grandmothers laptop and they sound perfect. Nothing wrong. Can you help me figure out what's wrong?
 
Since the speakers work with your grans laptop the problem is either in your PC or in the way the speakers or the power supply for them is connected. Try connecting the ps to a different ac outlet. If it has a three prong plug you can try a 3 to 2 ac ground lifter like this
http://www.parts-express.com/ac-3-prong-ground-lift-grounding-plug-adapter--110-211

You may be getting a ground loop in the audio from the PC. That can cause a constant buzz. Something like this might help:
http://www.amazon.com/Pyle-PLGI35T-8-Inch-Stereo-Isolator/dp/B004HJ35F2
 
Since the speakers work with your grans laptop the problem is either in your PC or in the way the speakers or the power supply for them is connected. Try connecting the ps to a different ac outlet. If it has a three prong plug you can try a 3 to 2 ac ground lifter like this
http://www.parts-express.com/ac-3-prong-ground-lift-grounding-plug-adapter--110-211

You may be getting a ground loop in the audio from the PC. That can cause a constant buzz. Something like this might help:
http://www.amazon.com/Pyle-PLGI35T-8-Inch-Stereo-Isolator/dp/B004HJ35F2
 

ASK THE COMMUNITY

TRENDING THREADS