Brightness fluctuations on brand new Dell Inspiron 7537

Kookas

Honorable
Aug 20, 2012
4
0
10,510
0
These aren't the automatic brightness kind. Rather, every three minutes or so, the screen will briefly go to maximum brightness and then almost immediately back to normal again. It's not a flicker - it changes gradually, like a deliberate software thing. But I've disabled automatic brightness in the Intel settings, I've disabled the sensor service, and I've disabled it in the power saving settings too.
 

jessterman21

Distinguished
Dec 14, 2010
49
0
18,590
3


Must be the driver, but even after a cold restart, still hasn't come back - plugged in or on battery. Weird.
 

JeckeL

Distinguished
Jul 19, 2009
224
1
18,910
41
Does the brightness meter appear on the screen when it's going up & down? Try turning off auto-function or whatever it's called so if some part of the case is putting pressure on the brightness buttons it'll activate the function keys instead of the alternative function
 

Kookas

Honorable
Aug 20, 2012
4
0
10,510
0
It is definitely something related to power settings. After a cold restart the problem came back, so I plugged it in and then unplugged it and the problem went.

I'm not sure how to disable the settings which make the laptop want to get brighter when plugged in or dimmer when not though. There seem to be so many of them.
 

JeckeL

Distinguished
Jul 19, 2009
224
1
18,910
41


You may want to check your power settings (When you said "these aren't the automatic brightness kind" I thought that meant you had already checked these settings), under control panel, power options, and look through "when to sleep", "closing the lid", etc... I would just disable the brightness settings all together unless you want it to go dim when it's running off battery and not connected to the AC adapter
 

jessterman21

Distinguished
Dec 14, 2010
49
0
18,590
3
I have the same exact problem. Dell Latitude E6420 that I just put an SSD in and a fresh copy of Windows 7. No flashing until I installed Intel's Graphics driver. Tried 3 different versions from Intel and Dell's websites, but each have the every-3-minutes-full-backlight-for-half-a-second issue.

I have worked around it by setting 100% brightness, but I'd really prefer a solution. It apparently is some glitch with the driver...

*edit - not doing it now that it's plugged in
 

Kookas

Honorable
Aug 20, 2012
4
0
10,510
0


Yeah. You found the exact same solution I just did. Plugging it in and then unplugging it causes the problem to go away until a cold restart. Some kind of bug, but with which software?

 

jessterman21

Distinguished
Dec 14, 2010
49
0
18,590
3


Must be the driver, but even after a cold restart, still hasn't come back - plugged in or on battery. Weird.
 
Thread starter Similar threads Forum Replies Date
Magnumconehead Laptop Tech Support 0
O Laptop Tech Support 1
S Laptop Tech Support 1
P Laptop Tech Support 1
B Laptop Tech Support 4
M Laptop Tech Support 1
M Laptop Tech Support 1
X Laptop Tech Support 1
J Laptop Tech Support 1
M Laptop Tech Support 1
W Laptop Tech Support 1
P Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 1
M Laptop Tech Support 5
J Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 2
S Laptop Tech Support 1
B Laptop Tech Support 3

ASK THE COMMUNITY