Cannon Rebel T3 55-250mm lens auto-stabilizer whine

unilateralis

Honorable
Apr 14, 2013
2
0
10,510
0
So I just dropped my telephoto lens for my Cannon T3. The lens still works, with zoom and autofocus, but the auto-stabilizer now vibrates and whines when in use.

The stabilizer seems to still work, although I'm not sure how to test this and find a conclusive answer.

I'm a college student without a means of transportation until I go home after the semester, and there are no nearby camera repair shops.

Should I just deal with the sound and vibration, or not touch it until I can get it to a repair shop?
 

USAFRet

Splendid
Moderator
vibrates and whines when in use

Something is out of alignment and rubbing. Presumably, the more you use it, the worse it will get.
Instead of taking it to a camera shop, can you mail it? Possibly back to Canon (might be expensive).
 

USAFRet

Splendid
Moderator
vibrates and whines when in use

Something is out of alignment and rubbing. Presumably, the more you use it, the worse it will get.
Instead of taking it to a camera shop, can you mail it? Possibly back to Canon (might be expensive).
 

unilateralis

Honorable
Apr 14, 2013
2
0
10,510
0


Thanks for the reply.
I only have a few weeks left of school, so I'm just going to let it alone and wait until I get back home.

I'm thinking it will be cheaper and faster to get it repaired at a local place than to send it in to Canon.
 
Thread starter Similar threads Forum Replies Date
S Digital Cameras 1
tyflikw Digital Cameras 2
J Digital Cameras 1
A Digital Cameras 5
V Digital Cameras 1
M Digital Cameras 2
C Digital Cameras 2
P Digital Cameras 5
K Digital Cameras 2
G Digital Cameras 5
A Digital Cameras 1
S Digital Cameras 1
P Digital Cameras 3
D Digital Cameras 1
M Digital Cameras 2
swilczak Digital Cameras 3
V Digital Cameras 7
C Digital Cameras 1
M Digital Cameras 3
J Digital Cameras 1

ASK THE COMMUNITY