Can't Access the Internet

Jun 12, 2018
1
0
10
0
Just got a new PC today, and the wifi won't work. I've tried updating, reinstalling and disabling/re-enabling the network adapter driver but that doesn't do anything.

I've tried forgetting the network and re-joining, the troubleshooter is useless. I've looked around for answers and tried heaps of different things but nothing is working.

I just hit the 'network reset' button and now the internet is working, but only at about 20 kb/s, which is absolutely not right. Running a speed test on my laptop shows it should be at least 30 mb/s. However, this keeps periodically dropping out and not letting me do anything on the internet.

I have no idea what is going on, this computer is 100% new and this seriously shouldn't be happening.

Can anyone help?

Update: I re-installed the drivers straight from the manufacturer's website, and generally it stays connected to the internet. But, it still isn't going above 0.2Mbp/s.
 
Thread starter Similar threads Forum Replies Date
Coldheartednite Laptop Tech Support 8
P Laptop Tech Support 2
B Laptop Tech Support 1
E Laptop Tech Support 2
B Laptop Tech Support 2
James T Kirk USS Enterprise Laptop Tech Support 6
N Laptop Tech Support 5
H Laptop Tech Support 1
W Laptop Tech Support 1
J Laptop Tech Support 1
J Laptop Tech Support 5
K Laptop Tech Support 3
C Laptop Tech Support 1
A Laptop Tech Support 3
R Laptop Tech Support 1
T Laptop Tech Support 5
D Laptop Tech Support 1
E Laptop Tech Support 5
D Laptop Tech Support 1
R Laptop Tech Support 1

ASK THE COMMUNITY