Connecting Speakers to Old Record Player

G

Guest

Guest
I have an old (30+years?) Poweray Stereo Record Player. It originally came with its own speakers. The speakers and the speaker connections on the record player have long since gone. I am now wanting to connect a couple of Wharfedale Modus speakers by connecting them to the wires inside the box that ran to the original speaker connectors. There are 3 wires (Black, Green and Blue) but I cannot get Stereo sound from the speakers.
I can only get sound if I connect the Black and Blue wires to the speakers. Black and Green produces no sound and neither does Green and Blue. At the moment I have both speakers connected to just the Black and Blue Wires. Any ideas on what the problem is?
 

Alec Mowat

Honorable
Jan 8, 2014
109
0
10,660
11


It sounds like the speakers that came with it had a built in amp.
 

Alec Mowat

Honorable
Jan 8, 2014
109
0
10,660
11
It almost sounds like it's missing the red.

If you are not to attached to the unit, open it open and look where the wires are coming from. See if a wire broke off the solder.
 
G

Guest

Guest


The wires are coming from the front panel with the volume, tone and balance controls. There are only 3 wires going in and 3 wires coming out. No indication of any other terminals which may have lost connection to another wire.

Curiously, I am testing with a stereo record that has very distinct stereo including the sound of a train passing by that normally travels from one speaker across to the other. The way I have the speakers connected actually gives me both channels of sound through both speakers.

 

Alec Mowat

Honorable
Jan 8, 2014
109
0
10,660
11
Just because the record has stereo, doesn't mean the speakers on the old record player do.

See if you can find a model number on the player, maybe we can search and find it's specs.
 
G

Guest

Guest


It's a Poweray Stereo sm-2-ic

I have played stereo records in the past when the old speakers were attached and definitely got stereo sound.
I also got stereo sound when the old speakers were attached to a more modern system

 
G

Guest

Guest


From memory (which may be incorrect) the original speaker connections were a DIN type with a central terminal and two terminals near the circumference.

 

Alec Mowat

Honorable
Jan 8, 2014
109
0
10,660
11


It sounds like the speakers that came with it had a built in amp.
 
G

Guest

Guest


I think that this seems the most likely scenario. Thanks for all your help.

 
Thread starter Similar threads Forum Replies Date
jasonch Audio 0
C Audio 0
D Audio 1
marz lee Audio 2
T Audio 3
F Audio 1
omqkarma Audio 1
K Audio 2
T Audio 1
W Audio 3
W Audio 2
N Audio 1
S860 Audio 1
J Audio 1
K Audio 4
B Audio 1
E Audio 1
M Audio 1
K Audio 9
C Audio 1

ASK THE COMMUNITY