Corsair Vengeance 2100, cant choose from playback devices

zalgocykel

Estimable
Apr 28, 2015
2
0
4,510
0
Hello,
I have a Corsair Vengeance 2100 headset. I have been using it for about a year. The last couple weeks I have used my speakers instead so I switched to them by going to playback devices. Today I was going to play with a friend so I went back to playback devices to switch back to my corsair headset. Only it wasn't there. I can start my headset and it seems to be connected, it blinks blue every second.

I have tried the following:

1. Show disconnected/disabled devices in playback devices
2. Removed the reciever and tried other USB ports

The thing with (2.) is that windows says it installs drivers correctly and that it is "ready to use".
So I don't really understand what im missing here...

Im using windows 7 with all the latest drivers.
 
Thread starter Similar threads Forum Replies Date
M Audio 1
S Audio 3
O Audio 2
C Audio 1
S Audio 1
O Audio 3
S Audio 5
Lan2u Audio 2
cyrusdobbs Audio 1
C Audio 1
L Audio 3
M Audio 1
Mr Aceman Audio 1
V Audio 5
B Audio 1
A Audio 9
T Audio 3
L Audio 1
InfinityBlaze Audio 2
olivierhacking Audio 1

ASK THE COMMUNITY