CPU caps at 30% under 40% battery

Kimimaru

Estimable
Nov 23, 2015
3
0
4,510
0
Hey everyone! Before I go into more detail here are my computer specs:

Laptop: Lenovo Y40-70
Processor: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz 2.60 GHz
RAM: 8 GB
OS: Windows 10 Home 64-bit (upgraded from Windows 8.1)
Graphics: AMD Radeon R9 M275
-RAM: 2 GB DDR3
-Core Clock speed: 925 MHz
-Memory clock speed: 1000 MHz
-Total Memory bandwidth 32 GB/s

So here's the problem: When running on battery, if I boot/restart my computer above 40% battery, when it reaches below 40% battery it maxes the CPU at 30% speed, resulting in it running very slow. If I reboot when it is under 40% battery, it then runs like normal and won't cap the CPU until I tell it to or reboot again when it is over 40% battery. This problem does not exist if the AC adapter is plugged in.

I checked the BIOS and found that all my P-states are set to max performance. In my battery settings I have the minimum and maximum CPU processor speed set to 75% and 100%, respectively, on battery. I tried changing the values but nothing seems to change this peculiar behavior.

I've also had the battery replaced recently since the old one was bad, but that wasn't the cause of the issue as it's been happening before that. It has also happened before the upgrade to Windows 10.

Any ideas? Thanks in advance!
 
Hi,

Please do try changing the Power Option of the processor of your laptop and see if that will help.
- Right click on the battery icon and select Power Options.
- Click Change plan settings then Change advanced power settings on the next window.
- Look for Processor power management:
Minimum processor state: 100%
System cooling policy: Active
Maximum processor state: 100%
- Click Apply and OK then observe it.
 

Kimimaru

Estimable
Nov 23, 2015
3
0
4,510
0

Thanks for the response! I tried what you suggested, but unfortunately it still caps the CPU at 30% speed.

EDIT: Another thing I noticed is that it still caps the CPU when I do a full shutdown and start it back up again when it's under 40% battery. A restart, however, causes it to run well again. Very strange.
 
Thread starter Similar threads Forum Replies Date
AjSpeedwagon Laptop General Discussion 2
Mayank Pokhriyal Laptop General Discussion 2
K Laptop General Discussion 1
sammanadh Laptop General Discussion 7
mukuljain02 Laptop General Discussion 3
sammin Laptop General Discussion 2
A Laptop General Discussion 1
alphacoyle Laptop General Discussion 3
O Laptop General Discussion 0
xiaomei106 Laptop General Discussion 2
J Laptop General Discussion 22
Aragorn Ann Laptop General Discussion 1
gomeskiran Laptop General Discussion 1
blzbnvntr Laptop General Discussion 6
K Laptop General Discussion 2
M Laptop General Discussion 1
H Laptop General Discussion 3
DANTE_newname Laptop General Discussion 4
H Laptop General Discussion 0
Kaitalb Laptop General Discussion 1

ASK THE COMMUNITY