Dell Laptop memory 4G issue

Apr 4, 2018
8
0
10
0
Hello everyone,
I own an Dell Latitude E5520m. In Tech specs, they say that this laptop can have max 8G Ram memory. By default, mine, has 2G.
I bought 2X4G memory Ram from Corsair DDR3, 1066MHZ wich specs are compatible with my laptop but the problem is that when i mount one 4G card on slot B, my laptop dosen't start.
The same card is working in slot A, and a 2G card is also working fin on slot B.
What do you think that is the problem?
Best regards!
Calin D.
 
Apr 4, 2018
8
0
10
0
Corsair CMSO4GX3M1A1333C9 Value Select 4 GB (1 x 4 GB) DDR3 1333 MHz CL9 is the new RAM, is working just in slot A, in slot B, isn't working.
 
Apr 4, 2018
8
0
10
0
i laso did that, both memory works fine in slot A but when i connect in slot B, my laptop dosen't start, is just vlack screen and then turn off, not even bios.
 
Apr 4, 2018
8
0
10
0
i also tried with kingston 4G modules and is the same situation, in slot B is not working. I guess that slot B can't handle moore than 2G., I was courious if somebody else has this situation before.
 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 1
O Laptop Tech Support 1
F Laptop Tech Support 1
C Laptop Tech Support 1
M Laptop Tech Support 19
mad_cat Laptop Tech Support 3
H Laptop Tech Support 3
P Laptop Tech Support 3
R Laptop Tech Support 1
W Laptop Tech Support 2
N Laptop Tech Support 1
M Laptop Tech Support 5
M Laptop Tech Support 2
A Laptop Tech Support 2
S Laptop Tech Support 13
Z Laptop Tech Support 3
M Laptop Tech Support 2
L Laptop Tech Support 2
J Laptop Tech Support 3
F Laptop Tech Support 1

ASK THE COMMUNITY