Game Disconnect on VM

Aug 31, 2018
Good morning everyone!
As a start i would like to apologize if this it the wrong secrtion :??:
I have an issue with a game on VIrtual machine, i will be more specific.
I created a virtual machine using VMware Workstation 14 pro, and I installed on it windows 10 Pro full updated (build 1803) and installed vmware tool too (for gpu driverand other).
Here comes my issue: when i start the game and and play it it goes well for 1st 15second-2minutes then it discnnect and i dont know why.
I tried to change connection type from NAT to bridged to host but i keep get disconnected. i tried to unistall all Network driver and restarted, and it failed.
I noticed that the network driver on VM and the driver on the host machine are different I tried to install on the virtual machine the same driver I have on the host machine but I couldn't since the setup didn't recognize any hardware for that driver.
I also tried to use other Virtualization programs such as the oracle one and Hyper V.

on Oracle VM virtual box the game doesn't even start and same on hyper-V
I also created virtual machine with different OS(windows7 pro) but it didn't work, keep disconnecting.
i checked if the problem was of the virtual network driver but it doesn't seem so because I executed a ping test while i started the game, and all packages got delivered even if the game says that I'm disconnecting.
the game is an MMO RPG, TPS

So i would ask your help to fix this issue because I have no other idea how to fix it, i tried everything i had on my mind so please help me. :ange:

here is ma platform specifics:

Cpu: Intel 8700K
GPU: Intel UHD 630
HDD: WDC WD4004FZWX (host machine)
HDD2: WDC WD5000BEVT(Virtual machine)
PSU: Corsair RM750i
OS: Windows10 Pro 1803
MoBo: Taichi z370


Apr 19, 2009
Think of the VM as a separate machine independent of the host. So its network card has nothing to do with the host hardware.

What game are you playing, does the VM meet the minimum hardware specification for that game?

do you have a firewall on your VM?