Getting 5.1 Surround Sound and Lag-Free Gaming using PC-Receiver-TV Connection

78_anon_anon_87

Estimable
Aug 31, 2015
3
0
4,510
0
Windows 7 64bit
CPU: Intel Core i5-2500K 3.3GHz Quad-Core Processor
Motherboard: Gigabyte GA-Z68X-UD3H-B3 ATX LGA1155
Video Card: AMD Radeon 6870 XFX HD-687A-ZDFC
Receiver: Yamaha RX-V371
TV: Samsung LED 39” FH5000
All drivers are updated.

I'm using 2 HDMI cables to try and accomplish 2 main things, 5.1 surround sound and smoother gaming. I’ve tried a few cable setups but I can only have one or the other.

If I connect an HDMI cable from the GPU to the Receiver (using and open HDMI slot) and I use the other HDMI cable to connect the Receiver to the TV (using the HDMI Out) I can get the 5.1 sound. But when I play story mode on games like Borderlands 2, the lag is really noticeable and irritating. This is what the "playback device option" looks like.


If I keep an HDMI cable from the GPU to the receiver but move the TV connection by way of HDMI from the video card I can get smooth gaming but now I have no sound and I’m left with this situation.


I can get Stereo audio of I use a RCA to 3.5mm jack via motherboard to Receiver and get smooth gaming if I connect an HDMI cable from the Receiver (HDMI Out) to the TV but I don’t get 5.1 surround sound.

It’s been weeks of tinkering and I’ve been using certain threads from Tom's as guidelines but I still can’t find my sweet spot. Not quite sure what is left to do.
 

ssddx

Glorious
Moderator
i personally use pc->receiver->tv and have zero noticible lag using that method. the hdmi output on your receiver should be direct passthrough.

i suspect that you might have some form of post processing turned on in the settings of your receiver. i would disable any upscaling, motion blur reduction or similar after effects as these cause lag.

similarly make sure your tv is set to 60hz mode and that 120/240hz or motion blur reduction is set to off as this induces noticeable lag.

it would also be possible for you to run a hdmi (or dvi to hdmi cable) direct to the tv from your video card and have a separate hdmi cable from your gpu or motherboard to the receiver and set the second hdmi as default audio device which would transmit audio data to your receiver using hdmi just like a direct connection should. it will show up as a 2nd monitor in the list but in fact displays no signal just audio transmission.
 

ssddx

Glorious
Moderator
i personally use pc->receiver->tv and have zero noticible lag using that method. the hdmi output on your receiver should be direct passthrough.

i suspect that you might have some form of post processing turned on in the settings of your receiver. i would disable any upscaling, motion blur reduction or similar after effects as these cause lag.

similarly make sure your tv is set to 60hz mode and that 120/240hz or motion blur reduction is set to off as this induces noticeable lag.

it would also be possible for you to run a hdmi (or dvi to hdmi cable) direct to the tv from your video card and have a separate hdmi cable from your gpu or motherboard to the receiver and set the second hdmi as default audio device which would transmit audio data to your receiver using hdmi just like a direct connection should. it will show up as a 2nd monitor in the list but in fact displays no signal just audio transmission.
 

78_anon_anon_87

Estimable
Aug 31, 2015
3
0
4,510
0
I turned off all the available post processing settings I could find on both the receiver and turned off a bunch of other settings on the TV but kept Gaming Mode ON. Still no change.

I used this post from overclock(http://www.overclock.net/t/1028415/how-to-computer-hdmi-sound-to-receiver-ati-hdmi) to try the second option but I still had very noticeable lag. So I tried it again for shits and giggles yesterday and today, but when I connect the (1)HDMI cable, motherboard -> Receiver and (2)HDMI cable Video Card -> TV I'm unable to detect the receiver as a 2nd monitor anymore under "Screen Resolution." So that's where I'm stuck at that juncture.

Do you think it's a hardware issue? Upgrading the motherboard and/or video card, or is it a A/V receiver issue?

Just to note I've been using these posts as guidelines if that helps you at all.
http://www.tomsguide.com/answers/id-1789875/surround-sound-hdmi-receiver.html
http://www.tomsguide.com/answers/id-2172101/connect-receiver-surround-sound.html
 

ssddx

Glorious
Moderator
http://www.avsforum.com/forum/143-general-gaming-help/1452009-input-lag-receivers.html
have a look at what they say about video direct mode. perhaps that will help.

it would be a quality loss (somewhat) but have you thought about using optical as a last resort?

i'm still thinking the lag must be due to processing or settings as the receiver on its own might have some input lag but nothing terrible.

by all drivers updated you meant both your graphics card AND onboard audio drivers right? its strange that your onboard options are not showing up (check box disabled / disconnected in playback devices to see if they show up there). if you have a dvi to hdmi cable perhaps try using dvi for video and hdmi for audio direct from your video card.

 

78_anon_anon_87

Estimable
Aug 31, 2015
3
0
4,510
0
BOOM! Got it.
Thanks a bunch ssddx.
The Video Card -> TV and the motherboard -> Receiver finally worked after plugging and unplugging a couple times. I keep reading about this "handshake" that the hardware does. Could that have been the issue where it just took a few times for them to handshake?
 

ssddx

Glorious
Moderator
hdmi handshaking can certainly be annoying at times, and certain models or brands i've noticed may have more trouble than others. my own experiences with handshaking are that the order you turn on devices can have something to do with it.

for instance if i start up my receiver, tv and pc at the same time - some of the time i have no sound but if i restart the computer i have sound. if i turn the tv and receiver on but wait 10-15 seconds or so until they are up and running and then turn on the pc it normally works fine. i chalk it up to hdmi handshake issues (though it doesnt have any issue with the ps3.. odd yes?)

 
Thread starter Similar threads Forum Replies Date
Paradar Audio 0
T Audio 0
JackMateo123 Audio 1
B Audio 5
D Audio 2
F Audio 10
K Audio 1
R Audio 1
O Audio 12
F Audio 1
S Audio 6
N Audio 2
chaos_viper15 Audio 5
S Audio 10
U Audio 1
B Audio 5
P Audio 1
malrats Audio 1
L Audio 2
L Audio 1

ASK THE COMMUNITY