Have to force the laptop to ignore switchable graphics, but how?


Dec 24, 2013
Hello gents,
Skipping the introductions and going right into the problem if it's okay.

I have a Samsung NP350E7C lap-top I use for gaming, it has an i5 processor, 8 gigabytes of ram and the bane of existence switchable graphics function(AMD 7670 - Intel HD 4000). For the past few months, I have been unable to play anything but World of Warcraft and Dragon Age: Origins on this computer due to the incredibly bad framerate.

Stuff I have tried so far:
Setting the game exes to "high performance" on switchable graphics menu.
Setting the lap-top to ignore power saving and go turbo at all times.
Turning powerplay on.
Using razer game booster.
Using cleaner tools to fix up the pc just for the heck of it.
Reinstalling directx.
Using BIOS to force the laptop to use 7670 instead(samsung bios does not have such an option, so I wasn't able to do this)

None worked. So I installed the latest leshcatlab drivers to get rid of the outdated 2012 drivers the lap-top had(followed every single instruction including the removal of previous drivers). Performance didn't improve the slightest(I even get fps drops in World of Warcraft since then for some reason, though relog fixes it). And now I can't set anything to use high performance gpu as well, because as soon as I save the settings they reset.

However, leshcatlab did add a new feature to the switchable graphics menu, a tool to see which application is running on which gpu. Turns out, ALL of the games I've been playing(for some reason except Dragon Age) have been running on Intel HD 4000 instead of 7670.

I verified this with a before-after test, I have been getting the same exact low fps in Bioshock Infinite for months(lowest settings, almost unplayable), the number is unchanged, so it's definitely not something leshcatlabs drivers messed up.

Now my question is, how can I get rid of that lousy HD 4000 for the pc to use 7670 at all times? Would deleting it from the device manager do?

Thank you.


Are you CERTAIN your model has the AMD GPU?

I went to the US support site and it makes no mention of it in the specs or the drivers.

However, it is listed at the UK site so I'm not sure what's going on. I couldn't even look at the list of software as it had to be AUTO DETECTED.

Most programs are supposed to auto switch but you can MANUALLY add them this way:

1. Right-click on the Desktop and select Configure Switchable Graphics from the popup menu.
2. Click the Browse button and register the software and click the Apply button.

If none of this is working, then contact Samsung.

1. Was this EVER working?
2. Normally you must use the provided drivers, HOWEVER, while I've never dealt with Switchable graphics I have found installing an OEM, non-vendor specific version of Windows allowed me to use the most recent compatible drivers.

It MAY be possible to install for example, Windows 8 OEM from scratch, plus the latest compatible Catalyst software and have better luck (may need to manually find drivers for OTHER things though).

If you can BORROW a legal, Windows 8 64-bit OEM install disc to test on a spare drive that would be ideal and not touch the original.

Good luck.


Dec 24, 2013
Thank you, but I did just update them both with the latest leshcatlab. I'm unable to download the official drivers, since neither AMD nor Samsung offers any support to the switchable graphics(catalyst control center disappears).


Samsung must have custom AMD drivers on their website for their own products. It would be highly unusual if they sold a laptop with switchable graphics and not provide the drivers for it.

Perhaps it is the leshcatlab drivers that are giving you problems now. I would do a clean install of Windows at this point, that may fix your issue.


Dec 24, 2013
Sadly it is true, the last Samsung switchable graphics drivers that do not mess up the catalyst control center date back to 2012, there was an outrage about this in the samsung boards actually.

And I'm fairly sure it is not the leshcatlabs drivers causing the issue, as pointed out here:

What I meant here was that the fps was the same before the installation of the new drivers.
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 0
L Laptop Tech Support 1
A Laptop Tech Support 1
A Laptop Tech Support 1
N Laptop Tech Support 1
R Laptop Tech Support 1
B Laptop Tech Support 2
A Laptop Tech Support 2
A Laptop Tech Support 1
D Laptop Tech Support 1
R Laptop Tech Support 4
L Laptop Tech Support 1
R Laptop Tech Support 3
Z Laptop Tech Support 1
D Laptop Tech Support 3
P Laptop Tech Support 4
R Laptop Tech Support 1
A Laptop Tech Support 2
K Laptop Tech Support 1
B Laptop Tech Support 3
Similar threads
Question Force laptop to boot to external monitor
Solved! Laptop suddenly restarted but won't turn on and won't even be forced shutdown
Solved! Force shutdown laptop on factory reset
Laptop doesn't work after force shutdown (long press power key).
My laptop is trying to recover because I force shut down to stop it updating, but now it's stuck on a never-ending cycle
laptop is not switching on for the first time if i push the power button but after force stop and on second push it is.....
Dell 7567 laptop: Forcing Windows 10 to use GTX 1050Ti instead of onboard GPU
Solved! Laptop freezes when plugged in, had to force shutdown
How to send audio to the laptops audio jack forcefully on windows
Acer aspire 5943G dark screen - cured by forced shutdown
Laptop wont turn on after a forced shutdown
Friends my laptop dell vostro 1540, I had force stop by removing battery due to physical memory dump. During physical memory
Random Restarts: Critical Kernel-Power, Event ID 41, Task 63 for a few days, now my laptop force shutdows during startup
Windows 7 keeps freezing and forces me to restart my laptop!
how i force my laptop to run graphics processor with nvidia in the same time for batter gaming ???
Accidentaly, without force, touched laptop's USB port with headphones' pin, now laptop won't turn on
Laptop turns off when placed down with little force?
Laptop Freezes and since nothing works, needs force Shutdown.
Need help forcing laptop to boot to CD/DVD in UEFI mode
Force laptop to run at full performance w/out recognizing AC