HDD Upgrade - Primary Hard Drive Not Found (Dell Inspiron 4100 )

trendski

Distinguished
Jan 25, 2010
7
0
18,510
0
Anyone any ideas why so far 2 different 2.5 IDE laptop drives (WD 320GB and Samsung 120GB) don't get seen by the BIOS?

Tried Dell Diagnostics disk which actually picks up identification info but flashes error that no valid FAT partition on the disk.

Tried formatting 25GB partition on another machine with NTFS but no joy when slotting into the laptop. It is as if the drive doesn't exist (except for the limited recognition by Dell Diagnostics).

After a lot of research into LBA etc I see that the Intel chipset is 830 so I am guessing the 48bit LBA is not supported by my laptop/BIOS. So in theory I am restricted to drives <137GB. However, I seem to get the same error with the Samsung 120GB. (Just to recap neither of the drives were dead as they were seen fine by BIOS of a desktop fitted with suitable adaptor).



In hindsight I should have got the guys that formatted the NTFS to use FAT instead. They didn't supply the drive so I can't really ask them to get involved again, but I could buy a cheap USB caddy and try that myself if I could be convinced it had a good chance of working.



Tried booting from various bootable utilities, Western Digital, Samsung, Linux etc etc all the same result Disk invisible.



Any ideas would be appreciated.



Thanks.
 

ram1009

Distinguished
Jun 28, 2007
439
0
18,960
14
I don't typically experiment with store bought computers for reasons you are now experiencing. My guess is that the Dell BIOS is looking for a "special" boot sector on the HDD placed there by (you guessed it) DELL. Not finding it the BIOS tells you to piss off. This is DELL's way of trapping you into buying your upgrade parts from them. Mind you, this is only a guess on my part but I have seen it many times in the past. This is the major reason I don't buy or work on store bought computers.
 

trendski

Distinguished
Jan 25, 2010
7
0
18,510
0
Thanks for the input. 10 minutes after I posted also to the Dell Community forum some genius suggested I might have overlooked the blade adaptor that enables the drive to connect to the system board on the laptop! I am not sure what other name it's called but yes he was 100% correct!!

I just love this Dell machine its such a workhorse and well designed for easy access. Their forums seem to be very good as well, and their driver support for even ancient machines still maintained. Its great to be able to extend the life of the machine.

I am thinking about building/assembling my own desktop but I want to find the right motherboard to be able to upgrade the CPU later on.

Its amazing how easy it is to overlook such a thing as the adaptor. None of the tech support folks anywhere I tried ever mentioned anything about adaptors! Nor does it seem to be documented as an issue when upgrading laptop drives.
 

ram1009

Distinguished
Jun 28, 2007
439
0
18,960
14
You don't really expect some tech to tell you how to fix something as long as he thinks you might have to pay him to fix it do you? Anyway, I"m glad you got it fixed. When you get around to building instead of buying try an AMD processor if you're interested im maximizing your CPU upgrade path. Intel is infamous for obsoleting their old systems forcing users to buy complete new systems. If you're not looking for bleeding edge max performance (and the price that goes with it) AMD is the way to go, IMHO. Have a look at ASUS & Gigabyte MBs also.
 

trendski

Distinguished
Jan 25, 2010
7
0
18,510
0
Hey ram you sure are a cynical one!

I think the drive pin blade adapter is something that seems to have been generally overlooked including the internet. No conspiracy theory needed, no deliberate traps, just good ole fashioned human error. At least in this case ;)

Thanks for the AMD comments
 

authoratah

Distinguished
Aug 29, 2007
3
0
18,510
0
I read the first few words of the OP title, and instantly thought "jumpers". Are your jumper settings correct?
 

trendski

Distinguished
Jan 25, 2010
7
0
18,510
0
I read the first few words of the OP title, and instantly thought "jumpers". Are your jumper settings correct?
Blade Adapter was the solution. I just hadn't noticed it. Kind of thing that slips under the radar!

Laptop drives don't need jumpers anyway I think. Thanks anyway.
 

ram1009

Distinguished
Jun 28, 2007
439
0
18,960
14


Cynical am I? Maybe you should look up the meaning of the word "naive".
 

Lusakaman

Distinguished
Aug 28, 2011
6
0
18,510
0
Thanks for your post. It may be the solution to my night mare.

I have an Acer Aspire 3002LC which I have upraded with a 320 GB WDC HDD but XP only sees 127 GB. I believe it may be because the BIOS HDD limit is 137 GB.

Back to your post! Where might this "drive pin blade adapter " be found and what does it look like?

Cheers
 
Thread starter Similar threads Forum Replies Date
DarkShadow464 Laptop General Discussion 2
Devanshukranjan Laptop General Discussion 4
Mordko Laptop General Discussion 6
ineuw Laptop General Discussion 2
Z Laptop General Discussion 2
Lazer9308 Laptop General Discussion 7
P Laptop General Discussion 0
S Laptop General Discussion 1
OofusDeletus Laptop General Discussion 3
Romanio0089 Laptop General Discussion 0
W Laptop General Discussion 6
A Laptop General Discussion 7
AssumingUnicorn Laptop General Discussion 2
FranticApples Laptop General Discussion 3
abbastahir555 Laptop General Discussion 3
nako2007 Laptop General Discussion 1
T Laptop General Discussion 1
M Laptop General Discussion 0
Starwraith Laptop General Discussion 1
F Laptop General Discussion 1

ASK THE COMMUNITY