Headset Audio Balance Problems

Yudodisy

Honorable
Aug 4, 2013
1
0
10,510
0
I just bought a Artemis Spectrum Snow 7.1 surround gaming headset. It is connected to my computer via a wireless usb. The audio is not balanced. In my sound options under "Levels" where the balance option is usually found there is no option. I have tried using Realtek HD Audio Manager to adjust the balance but it does not effect it at all. I also tried using a program called Volume 2 which did not help either. I can't connect the audio via the audio ports on the front of the pc because my case isn't connected to the motherboard so I have to use the wireless USB.
 

Lutfij

Splendid
Moderator
Have you tried installing the Logitech Gaming app?

Realtek's drivers have nothing to do here. The audio equipment is powered off the USB port and as such all processing is taking lace there. You should make sure you're on:
1| The latest BIOS revision for your motherboard
2| You're on the latest USB/chipset drivers
3| You should try and see if the audio equipment works when plugged to the PC directly/via wire...and if it does work, then it's the wireless USB.
 

Lutfij

Splendid
Moderator
Have you tried installing the Logitech Gaming app?

Realtek's drivers have nothing to do here. The audio equipment is powered off the USB port and as such all processing is taking lace there. You should make sure you're on:
1| The latest BIOS revision for your motherboard
2| You're on the latest USB/chipset drivers
3| You should try and see if the audio equipment works when plugged to the PC directly/via wire...and if it does work, then it's the wireless USB.
 
Thread starter Similar threads Forum Replies Date
T Audio 1
S Audio 1
E Audio 2
F Audio 0
B Audio 0
T Audio 0
Captain Kino Audio 0
S Audio 3
L Audio 0
jdip13 Audio 2
M Audio 0
C Audio 0
J Audio 0
ssrn510 Audio 1
aiden_crawford Audio 1
F Audio 1
K Audio 1
B Audio 4
AuGZA Audio 12
K Audio 5

ASK THE COMMUNITY