hello cant download anythig from google play keeps saying error retrieving information from serverrpc:s-7:aec-0

I would first check and see if you are using latest version of Google Play. If you aren't, then I suggest updating it.


RPC:AEC:0 error is known as CPU/RAM/Device/Identity failure.


Try this to see if it will get rid of the error...

Go into "Settings", then into "Application". Now choose "Play Store" and then "Disable".

Now restart the device.

When it has finished restarting, go back to "Settings", then into "Application". Now choose "Disabled" and then "Play Store" and finally "Enable".


Another possible fix would be to...

First go into "Settings", then into "Application". Now choose "Play Store" and then "Clear Data & Clear Cache".

Next go to "Accounts", and select "Google", then "Remove Account".

Now reboot your device.

Then reset up your Google account. This should solve the issue.


If none of this works, then only thing left I could suggest would be a "Hard Reset" and that is a last resort option, as it wipes your data.
 
Thread starter Similar threads Forum Replies Date
Leeigh Android Tablets 1
Z Android Tablets 3
P Android Tablets 1
G Android Tablets 3
S Android Tablets 1
A Android Tablets 1
K Android Tablets 2
J Android Tablets 1
C Android Tablets 1
M Android Tablets 1
N Android Tablets 6
W Android Tablets 1
S Android Tablets 1
F Android Tablets 1
C Android Tablets 1
T Android Tablets 1
W Android Tablets 1
V Android Tablets 4
M Android Tablets 1
C Android Tablets 1
Similar threads
Question Game download
How to download apps to SD card in Android tablet that is mounted and registered as default writer
My RCA Viking Pro tablet will not download fast or even use internet fast it's extremely slow what can I do
Solved! Failed to Download due to Missing SD card
Solved! Cant download app on tablet
Solved! how do I fix the download failed because the external storage is full for knights of the old republic on kindle fire
Solved! Using my phone's hotspot my RCA Voyager 3 tablet keeps telling me all downloads are pending how do I get it to download
Solved! RCA Cambio 2-n- 1 tablet
Solved! Black screen with Android downloading
Solved! download install os
Solved! sound and download not working
Is there any way to transfer/move/download TouchWiz from an Android 4.4.2 to an RCA anything tablet? i ask only b/c i have 12,
can i download windows to my rca viking pro?
If i download new one i lost all steps i did it
I download Hay Hay in 2014 my farm name. is Carolyn farm I have played it now it won't come up on this tablet
How to move photos on Huawei Tablet M3 10" tablet to a different folder, currently in download folder
Can't get games to open on new smart tab do I need to download something
samsung s2 versus teclast m89 wifi download very different
I keeping finding apps like coordinator downloaded on my tablet even though I have both unknown sources and automatic updates
How do I set up the default location of downloads to external SD on my elecost tablet?

ASK THE COMMUNITY

TRENDING THREADS