help, amd omega driver laptop win 8.1 issue

warshunn333

Estimable
Oct 25, 2014
5
0
4,510
0
So, i just upgraded my laptop's win 8 to win 8.1, and upgraded my AMD GPU's driver from 14.4 to the latest 14.12 driver, or the Omega Driver on my AMD Radeon HD 7670M right after upgrading my OS.
But strangely enough, after finished upgrading the driver, and rebooting two times, i noticed that windows automatically stopped both my AMD GPU and my Intel HD GPU, as seen in the Device Manager, and my screen have this strange, slight blue tint too.
Are there any solutions to this..?
Oh and, i didn't uninstall my old driver prior to updating.
My laptop is a Sony Vaio 14E
Thanks
 

warshunn333

Estimable
Oct 25, 2014
5
0
4,510
0
Well, just fixed it, the trick, is to install the latest intel drivers, THEN the latest AMD driver which is the Omega Driver.
Really satisfied with the greatly improved performance :)
 

vmk0888

Estimable
Mar 4, 2015
1
0
4,510
0
Hi warshunn333 ..I have same problem on windows7.. Did u download the GPU drivers from respective Intel and AMD websites..?
 

warshunn333

Estimable
Oct 25, 2014
5
0
4,510
0

Yes i did, but, you must install intel's first, then followed by AMD
 
Thread starter Similar threads Forum Replies Date
ahindi Laptop Tech Support 0
D Laptop Tech Support 5
eslam0stafa23 Laptop Tech Support 1
M Laptop Tech Support 0
K Laptop Tech Support 2
D Laptop Tech Support 3
T Laptop Tech Support 1
S Laptop Tech Support 1
L Laptop Tech Support 3
G Laptop Tech Support 5
Srijal Kc Laptop Tech Support 2
K Laptop Tech Support 5
G Laptop Tech Support 3
T Laptop Tech Support 4
Sabug Laptop Tech Support 2
AmazonTheGamer Laptop Tech Support 1
F Laptop Tech Support 1
J Laptop Tech Support 3
A Laptop Tech Support 1
N Laptop Tech Support 12

ASK THE COMMUNITY