help, amd omega driver laptop win 8.1 issue

warshunn333

Estimable
Oct 25, 2014
5
0
4,510
0
So, i just upgraded my laptop's win 8 to win 8.1, and upgraded my AMD GPU's driver from 14.4 to the latest 14.12 driver, or the Omega Driver on my AMD Radeon HD 7670M right after upgrading my OS.
But strangely enough, after finished upgrading the driver, and rebooting two times, i noticed that windows automatically stopped both my AMD GPU and my Intel HD GPU, as seen in the Device Manager, and my screen have this strange, slight blue tint too.
Are there any solutions to this..?
Oh and, i didn't uninstall my old driver prior to updating.
My laptop is a Sony Vaio 14E
Thanks
 

warshunn333

Estimable
Oct 25, 2014
5
0
4,510
0
Well, just fixed it, the trick, is to install the latest intel drivers, THEN the latest AMD driver which is the Omega Driver.
Really satisfied with the greatly improved performance :)
 

vmk0888

Estimable
Mar 4, 2015
1
0
4,510
0
Hi warshunn333 ..I have same problem on windows7.. Did u download the GPU drivers from respective Intel and AMD websites..?
 

warshunn333

Estimable
Oct 25, 2014
5
0
4,510
0

Yes i did, but, you must install intel's first, then followed by AMD
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 1
N Laptop Tech Support 2
Anonymous_7791 Laptop Tech Support 4
mikmikasd Laptop Tech Support 2
S Laptop Tech Support 2
B00MSTAM Laptop Tech Support 2
D Laptop Tech Support 0
Supertoine_FR Laptop Tech Support 0
I Laptop Tech Support 3
A Laptop Tech Support 1
Basem16 Laptop Tech Support 1
S Laptop Tech Support 0
F Laptop Tech Support 0
xxmac Laptop Tech Support 1
Manuja55 Laptop Tech Support 2
T Laptop Tech Support 1
vronti Laptop Tech Support 0
N Laptop Tech Support 2
A Laptop Tech Support 1
N Laptop Tech Support 12

ASK THE COMMUNITY