HELP my Zenbook will not turn on


May 18, 2016
this is a UX303L
Unit will not power on. Press On and the on button lights for about 2 seconds, the cap lock blinks, the HD LED blinks and then nothing. I've removed the back and unplugged the battery for about a minute and then tried again but have the same.
Any ideas?

Here are some troubleshooting steps that may help.
- Start by doing a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If this will not work, do test the AC adapter if it's working properly. Remove the battery and power the laptop with just the AC adapter connected and see if it will boot up or not. do also try a different AC adapter that has the same voltage and see if it will work or not.
- Proceed with reseating the RAM's if trying a different AC adapter will not work, remove them all for couple of seconds then put them back in making sure everything is seated properly.
- If it will still not work, connect an external monitor and see if you'll get any display from it. If there's a display on the external monitor that could mean that the problem is the built in display.
- If it will display on the external monitor, press the Windows key + P at the same time and select Computer Only and see if it display back on your built in display.
- But if there's still no display on the external monitor that means the problem lies in the motherboard.