HELP PLEASE Audio is messed up after cleaning PC from dust

marxman224

Honorable
Feb 2, 2014
10
0
10,560
0
I recently dusted my PC(Asus Cm1740) and when I turned it on and started playing music, I would hear a static or white noise sound whenever I changed the volume on my steel series Siberia. I tried it with speakers, and with the speakers theres normally a small buzzing noise but when I turned them on it was louder than normal. Oh lordy! Can anyone help? Thanks in advance. (BTW PC is 3 years old, not sure if its dying out)
 

i7Baby

Dignified
BANNED
Did you dust it out while it was powered on? I think you've injured the motherboard. But test a few things - play music through the speakers and check the connections at the back of the pc and that same cable at the speakers. Did you move the case when you were dusting it?
 

i7Baby

Dignified
BANNED
Did you dust it out while it was powered on? I think you've injured the motherboard. But test a few things - play music through the speakers and check the connections at the back of the pc and that same cable at the speakers. Did you move the case when you were dusting it?
 

marxman224

Honorable
Feb 2, 2014
10
0
10,560
0


No it was turned off while I was dusting, I guess it budged a little bit when dusting it, but thats all I did.

EDIT(Rather a THIS JUST IN): The steel Series Siberia headsets work now, it was the extension cord that was broken.
 
Thread starter Similar threads Forum Replies Date
TheMuppetMan Audio 1
D Audio 2
C Audio 1
fiachrab Audio 1
W Audio 3
P Audio 2
R Audio 0
Sentyee Audio 0
Brysonlee Audio 0
DakiMC Audio 1
Z Audio 3
komazumi Audio 0
T Audio 0
W Audio 2
Alec S Audio 1
N Audio 1
X Audio 5
P Audio 10
Y Audio 10
B Audio 4

ASK THE COMMUNITY