Hisence 50K610GW led lcd tv

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0
My smart tv model. 50K610GW S/N 50G124909H00879 Manufacture Feb 18 2013 has a issue that I want to ask help on fixing it. The TV turns on get sound but no picture.
 

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0


 

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0
The TV before a black screen was a half screen vertically white an the other half was a clear picture I checked the tcon board an on the right side that was white the ribbon was not connected when I connected it I last the half screen that was working making it a black screen.
 

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0


It went black then I disconnected it an it went to half a white screen an a half good picture screen
 

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0
digitaldoc said:
So, did reconnecting the ribbon get it fixed, or just alternate black to white?













It went black then I disconnected it an it went to half a white screen an a half good picture screen the way it was
 

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0


THANK YOU FOR YOUR HELP I REALLY DO APPRECIATE IT. IS MY TCON BOARD THE PROBLEM? PLEASE LET ME KNOW IF YOU DONT MIND.. THE WHOLE SCREEN BECAME BLACK
 

Carlos Salas

Estimable
Jun 15, 2015
8
0
4,510
0
digitaldoc, i took the ribbon on the left side of the tcon board an tried it on the opposite side to check if ribbon was the problem an i disconnected the other to check if its the ribbon and doing that was able to show half of screen was a clear picture. on the ribbon of the white screen.
 

ASK THE COMMUNITY