How to disable laptop HDMI port by software? (problems with hdmi switch)

HellandBoe

Estimable
Feb 9, 2015
2
0
4,510
0
TL : DR
Is there a program/software (windows 7) change that can force the HDMI port on the pc to stop send signals?

This is a copy of my question @ SuperUser, you can find the original post here.

____________


I have a automatic/intelligent HDMI switch. Automatic in the way that it always switch to the latest input that receives signals.

I have connected a laptop (Windows 7, ati 4670 with official catalyst 10/15/2013 driver (latest available per today) in one input and a DVR (Tv-decoder) in another input, and the output to a projector.

The problem is that the DVR always send out HDMI signals, as it it don't get turned off with the power off button, its only set in standby mode. The pc also send out signals if it is in sleep mode. When pc or DVR is set in standby and then turned back on, the switch won't react as the HDMI port still send signals when its in standby/sleep.

Scenario: I am using the pc and then turn on the DVR (to watch tv) the projector still will show pc screen. If I set pc in sleep, the projector goes black, but the HDMI switch is still set at the PC. If i disconnect the HDMI cable from the pc (or turn the pc off), the switch switches to DVR, and it shows on the projector. I don't want to shut the pc down to watch tv.

The question is, is there a program/software change that can force the HDMI port on the pc to stop send signals, so that the switch will switch from pc to DVR?

Info:

Put pc in sleep mode - No reaction on the HDMI Switch
Windows-key + p -> deactivate second display - No reaction on the HDMI Switch
Put pc in hibernate mode - Changes to DVR
Power off pc - Changes to DVR
Unplug HDMI - Changes to DVR
HDMIYO / HDMIOn - The laptopscreen flashes, but no reaction on the HDMI Switch
Tried search for options to disable hdmi in Windows Device Manager, but seems only possible to disable HDMI Sound, or to disable other ports like USB.
 

HellandBoe

Estimable
Feb 9, 2015
2
0
4,510
0
Thank you for the reply, I this what you suggest:
right click at desktop -> screen resolution -> the "show desktop only on 1" in the multple displays drop down.

This makes the screen black, it still shows as connected. The hdmi switch dont react.
 
Thread starter Similar threads Forum Replies Date
HPMelee Laptop Tech Support 0
S Laptop Tech Support 0
K Laptop Tech Support 14
L Laptop Tech Support 6
K Laptop Tech Support 0
K Laptop Tech Support 3
T Laptop Tech Support 6
O Laptop Tech Support 1
C Laptop Tech Support 2
D Laptop Tech Support 1
T Laptop Tech Support 6
L Laptop Tech Support 3
R Laptop Tech Support 1
G Laptop Tech Support 14
D Laptop Tech Support 3
L Laptop Tech Support 1
J Laptop Tech Support 1
H Laptop Tech Support 1
J Laptop Tech Support 2
B Laptop Tech Support 9

ASK THE COMMUNITY

TRENDING THREADS