Question How to fix my kdlinks A400 TV-BOX Problem?


Oct 20, 2013
I have a kdlinks A400M Android Media Player . I tried to upgrade its firmware which was based on the Android 5.It was unable to boot showing kdlinks logo.
I tried to install the zip file: #1 Build number HMD-2.0.6 2017-11-05.11415 which is
provided on the official website of Kdlinks, first.
What I did was based on these:
1. Copy to the root of a USB pen drive (so the USB pen drive should contain a single file named

2. Insert the USB pen drive into any USB port of the KdLinks A400.

3. With the A400 4K3D turned off, use a paper clip or pen to press and hold the the pinhole restore button on the back of the KdLinks A400.

4. While keeping the restore button pressed, turn on the KdLinks A400.

5. Keep the restore button pressed until you see an Android droid logo.

6. Release the button and the firmware upgrade will proceed.
which is recommended on the official web site of kdlinks.
But My bad during the update due to a problem I had to disconnect the USB.
Now I am trying to reinstall the upgrade zip file after doing a
FAT32 computer reformatting for the USB and pressing the "UPGRADE" button on
the rear of the unit again,but there is no
reaction from the kdlinks.
what do I do?Should I wipe anything?How?
please help me.
Many thanks