How to reduce GPU Temprature in lenovo Y510P Laptop ?

mageshwaran

Estimable
Apr 12, 2014
2
0
4,510
0
I am having Lenovo Y510P, Core i7 4700 MQ Processor, 8GB RAM, 2gb DDR5 nvidia 755M GPU

Usually the temperature lies between 40 - 45 deg Celsius but when i play games like Far Cry 3, NFS Rival the temperature reaches 87 deg Celsius in just 5 mins.
My GPU utilization is always 98 - 100 %, I tried cooling pad but it is of no use, i changed the settings to low resolution, i tried using it on a flat hard surface but the temperature remains high.

I think my GPU is overclocked how to prevent it from overclocking so that i can reduce the GPU usage below 75 % or is it malfunction of my laptop, is there any other way to reduce the temperature.

Help Regards...:pfff:
 

Catalyzer

Estimable
Apr 7, 2014
13
0
4,570
1
Gaming laptops suffer a lot from heat issues.
I still dont udnerstand why do people think of laptops for gaming ?
If portability isnt your concern , in that same price you canbuild a pretty beefy PC Spec.
OT : Try lowering your settings , goto the control panel of your GPU and try to downclock it if you can (i never tried it actually)
Provide adequate cooling to it like the cooling pad you just mentioned.
Apart from that i cant think of much.
 

cst1992

Honorable
Nov 8, 2013
21
0
10,570
1

The control panel does not provide direct overclocking capability. Also, when you overclock a card yourself, you cannot "save" the overclocked settings in the card. You'll have to run the software you used to overclock while gaming.

@OP
Overclocking doesn't work like that. Think of higher clocks as higher performance(in basic terms). If you increase a card's clocks, its usage will come down for a given FPS, but it'll consume more power and run hotter.
I don't think your card is overclocked, I've never heard of an overclocked laptop GPU. As for the temperatures, unless you have any unexpected shutdowns or anything like that, consider the temperatures to be normal. I have a i5 4200M CPU and it gets hot too when gaming.
 

Ali Vegeta

Estimable
Jun 6, 2014
8
0
4,520
1
i think the gpu is overheating because of gpuboost 2.0...........when ur playing demanding games its overclocking itself .......so there must be a way to disable gpuboost 2.0 ......same thing with turbo boost technology for intel cpu's...................................
 

FixMyLaptop

Estimable
Jun 7, 2014
3
0
4,510
0
Hi Mageshwaran,

Heres a easy solution to stop overlocking on the y510p

1. Click on the battery icon on the bottom right corner of your screen
2. Click More power options
3. Click on "Change plan settings" make sure to note if you are using Balanced or High performance plan
4. Click "Change advance power settings"
5. Click "Processor Power management"
6. Change maximum processor state to 99%
7. Apply and check your task manager. Ghz should not go over 2.4Ghz now
 
Thread starter Similar threads Forum Replies Date
MidasTouche Laptop Tech Support 0
S Laptop Tech Support 1
mk716 Laptop Tech Support 1
S Laptop Tech Support 1
E Laptop Tech Support 5
A Laptop Tech Support 3
A Laptop Tech Support 1
B Laptop Tech Support 3
F Laptop Tech Support 1
J Laptop Tech Support 1
A Laptop Tech Support 18
G Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 2
F Laptop Tech Support 5
S Laptop Tech Support 3
L Laptop Tech Support 2
D Laptop Tech Support 1
T Laptop Tech Support 6
J Laptop Tech Support 1

ASK THE COMMUNITY