HP Compaq CQ60 not working

Jun 12, 2018
5
0
10
0
Hello.
I'm writing from Italy.
I have this CQ60 which was not showing anything on display, neither by plugging an external monitor.
I thought the video card had gone and I replaced the mobo with a working one, but the problem remains.
I am an amateur hardware fan.
The fan works, the lights go on but the display is black.
On the palmrest's bottom left hand side there are three small leds: only the first one lights up, the one I think that shows that power is on.
I never had this problem before.
Can anyone help?
Thanks a lot and best regards
 

Lutfij

Splendid
Moderator
Do you see any LED flashing if you remove the ram from the board? You may want to see if the HDD works by connecting it to a desktop. Chances are that the ram may be faulty if your HDD is intact and that the motherboard is known working.
 
Jun 12, 2018
5
0
10
0
I shall try as you say but previously I tried various Ram but the problem remained. Also I dont know about the HDD but what I know is that I cannot even access the Bios.

Yes there is. I took the rams off and turned the laptop on. On top of the keyboard frame there is a white led flashing.
 
Thread starter Similar threads Forum Replies Date
A Laptop General Discussion 4
V Laptop General Discussion 3
xiaomei106 Laptop General Discussion 4
CHUGGUM Laptop General Discussion 0
N Laptop General Discussion 1
P Laptop General Discussion 2
P Laptop General Discussion 11
F Laptop General Discussion 2
S Laptop General Discussion 2
M Laptop General Discussion 11
K Laptop General Discussion 1
G Laptop General Discussion 1
G Laptop General Discussion 1
A Laptop General Discussion 3
J Laptop General Discussion 1
W Laptop General Discussion 8
yummymummyx Laptop General Discussion 1
G Laptop General Discussion 1
Q Laptop General Discussion 7
N Laptop General Discussion 9

ASK THE COMMUNITY