I have a Aspire One CloudBook 14 and It won't start.

Karmaxyooj

Commendable
Jun 20, 2016
1
0
1,510
0
My aspire one cloud book 14 does not have a Battery under it where you can take the battery out. I held my thumb on the power button for a minute,charged it but nothing worked pls help. it would look powered but the screen would be black.
 
Hi,

Please do try these troubleshooting steps that may help.
- Here's a video guide on how to open the laptop so you can reach to the battery.
- https://www.youtube.com/watch?v=gRP2CbhyNCo
- First is to just disconnect the cable that connects the battery to the motherboard then unplug the AC adapter then press and hold the power button for 20 seconds then try booting up again.
- If it will not work just leave the battery unplugged then connect your AC adapter and see if the laptop will boot up or not.
- Next to try is a different AC adapter, get one that is exactly the same with your AC adapter then test it with your laptop if it will boot up or not.
- Do also try connecting an external monitor and observe if you're going to get a display from it because if you will that problem may lie with the LCD.
- If it will still not work, do contact ACER first if it's still under the factory warranty.
 
Thread starter Similar threads Forum Replies Date
X Laptop Tech Support 1
W Laptop Tech Support 5
G Laptop Tech Support 1
C Laptop Tech Support 4
J Laptop Tech Support 3
K Laptop Tech Support 1
E Laptop Tech Support 3
C Laptop Tech Support 2
T Laptop Tech Support 5
A Laptop Tech Support 1
R Laptop Tech Support 1
C Laptop Tech Support 2
B Laptop Tech Support 1
P Laptop Tech Support 1
L Laptop Tech Support 1
C Laptop Tech Support 3
L Laptop Tech Support 2
K Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 3

ASK THE COMMUNITY