Solved! Inspiron 5770 with brand new battery shuts off after 1 min.

Nov 26, 2019
2
0
10
0
Hello, I have 18 monts old Inspiron 5770 17in. recently the battery has died.
So I replaced with brand new genuine Dell battery.
And upon powered on it charged 100 % and worked about 1 min or so and suddenly it shuts off.
When I plug in AC it works fine with no issues, but when I unplug the AC adapter, it shuts off.
I have run full diagnostic with no problems.
Checked the battery in BIOS the status healthy excellent.
Updated driver. ACPI -Compliant control Method battery
System is up to date.
Any help would be very appreciated.
Thank you
 
Last edited:
When you added the new battery, even though it said it was charged, I would still suggest letting it get a charge for a while (charger connected) to see if it is giving you a false reading. New batteries don't normally come fully charged.

Also, even if it is a DELL battery, it still could be the battery that is the problem. Sometimes they just don't work. I would suggest returning it and have them send you another.

If that does not resolve it, then I would check the connectors (where the battery meets the laptop) and make sure nothing was damaged, bent, etc.
 
When you added the new battery, even though it said it was charged, I would still suggest letting it get a charge for a while (charger connected) to see if it is giving you a false reading. New batteries don't normally come fully charged.

Also, even if it is a DELL battery, it still could be the battery that is the problem. Sometimes they just don't work. I would suggest returning it and have them send you another.

If that does not resolve it, then I would check the connectors (where the battery meets the laptop) and make sure nothing was damaged, bent, etc.
 
Nov 26, 2019
2
0
10
0
When you added the new battery, even though it said it was charged, I would still suggest letting it get a charge for a while (charger connected) to see if it is giving you a false reading. New batteries don't normally come fully charged.

Also, even if it is a DELL battery, it still could be the battery that is the problem. Sometimes they just don't work. I would suggest returning it and have them send you another.

If that does not resolve it, then I would check the connectors (where the battery meets the laptop) and make sure nothing was damaged, bent, etc.
Thank you for replying.
The battery came half charged and I charged to full.
I have checked the connector battery - motherboard, visually it looks good.
The old battery before it died completely, would have similar problems, it could shoots off on 35% power left. Maybe it is not the battery but some power circuit ? I do not know I am not an expert.
I have send request to exchange the battery and I am waiting for the response.
Thank you again.
 
Last edited by a moderator:
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 0
J Laptop Tech Support 7
A Laptop Tech Support 2
AD2021 Laptop Tech Support 1
Abdullah Javed Laptop Tech Support 0
hoskle Laptop Tech Support 1
madzhege Laptop Tech Support 1
F Laptop Tech Support 2
Manu2465 Laptop Tech Support 1
G Laptop Tech Support 1
B Laptop Tech Support 3
I Laptop Tech Support 3
IC_Dev Laptop Tech Support 0
tbone10588 Laptop Tech Support 1
M Laptop Tech Support 3
B Laptop Tech Support 4
T Laptop Tech Support 1
T Laptop Tech Support 4
E Laptop Tech Support 2
Kookas Laptop Tech Support 7

ASK THE COMMUNITY