is 5.1/6.1 surround available for windows 10 AT ALL

MoranJake

Prominent
Jun 5, 2017
4
0
510
0
The situation:
my uncle gave me a 5.1/6.1 surround system (inspire 6.1 6700) as i built a new setup and he had no use for it with his broken pc.
he had windows 7

i set it up to test and only the front two speakers were working, i plugged these into the rear jacks on the subwoofer and then only the 'rear' (front) ones worked.

i bought a cheapish soundcard as i thought that might solve the issue as the ports could be incorrect.... i was wrong

i scowered the internet only to find that its playing in stereo and bascially theres no solution...

can anyone help? twould be muchly appriciated as i am stuck and out of ideas.

spec:
i5 4690
msi z97 pc mate
16 gb ddr3
cheapo soundcard LOL
windows 10 home
windows build: 15063.332
version: 1703

thanks, Jake
 

ssddx

Glorious
Moderator
what i dont understand is why you would buy a no-name china soundcard for 12gbp when a name brand asus dg/dgx is 20gbp.

you could certainly test the rear speakers to see if they are functional by plugging into the front port but i'm thinking the speaker system is likely fine.

it could be the soundcard not working correctly or the drivers that came with the soundcard not working with windows 10. it is a cheap no-name brand so i wouldnt expect much there.
 
This speaker needs three separate connections to your soundcard. What is this "cheapo lol" soundcard? When you test the spealers setup from Control Panel, do you hear all speakers?
I am driving similar set of speakers, thru an external USB soundcard, under Windows 10, with no problems.
 

MoranJake

Prominent
Jun 5, 2017
4
0
510
0


hi, sorry the soundcard is from amaon (https://www.amazon.co.uk/gp/product/B01MRZ9ZC0/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1) and it has all the neccasery 3 ports (green, orange, black) thats why i bought it as my motherboard doesnt have them.
When i test the speakers i only hear the front two when they get 'bleeped' so to speak... however, i know that the rear speakers are functional as i hear the fuzzy interferance kind of sound that proves theyre working.
like i said, if i plug the rear speakers into the front ports they work?
what kind of settings or usb soundcard do you use?
thanks, jake.
 

MoranJake

Prominent
Jun 5, 2017
4
0
510
0


i do indeed have all of the neccasery ports with the sound card i bough (reason for purchase) and i can also hear the fuzzy interferance sound which indicates the rear speakers are working, they just do not play any sound. not with movies (dolby 5.1) music or games.
Thanks, Jake.
 

ssddx

Glorious
Moderator
what i dont understand is why you would buy a no-name china soundcard for 12gbp when a name brand asus dg/dgx is 20gbp.

you could certainly test the rear speakers to see if they are functional by plugging into the front port but i'm thinking the speaker system is likely fine.

it could be the soundcard not working correctly or the drivers that came with the soundcard not working with windows 10. it is a cheap no-name brand so i wouldnt expect much there.
 

MoranJake

Prominent
Jun 5, 2017
4
0
510
0


i shall try another one when i have the funds, thank you... ill update the thread when i do so
 
Thread starter Similar threads Forum Replies Date
A Audio 4
I Audio 12
D Audio 3
N Audio 2
H Audio 3
L Audio 2
C Audio 2
J Audio 1
A Audio 1
H Audio 28
P Audio 1
CmdrJeffSinclair Audio 3
J Audio 1
MystoPigz Audio 2
M Audio 4
F Audio 2
S Audio 2
akaikisaki Audio 2
T Audio 1
L Audio 1

ASK THE COMMUNITY