Question Is External NTFS Drive always supposed to be 'ON'?

OhGod

Great
Feb 17, 2020
50
3
85
0
Hi.

Formatted an external drive into an NTFS file system and moved some programs to it. (Mostly browsers, editing software, cleaning software, software to manage my iPhone, system tweakers, a driver updater and I also made a copy of my .mp3 files just as a backup. Well, this morning it was not showing up as a valid drive despite still being connected (via a KVM). I've had bad experiences with external drives, so that worried me. After reconnecting it, I realized that it won't stop running. It seems to always be on/working. I turned off search indexing on just that drive thinking that might be the issue, but it's still running. I then moved some portable programs off of it. Nothing. Still running. Short of deleting / uninstalling EVERYTHING from it, what can I do? I am going to be livid if another external drive fails on me. (It's a Seagate Backup Plus). Any thoughts please???
 
Thread starter Similar threads Forum Replies Date
N Laptop Tech Support 0
OhGod Laptop Tech Support 0
M Laptop Tech Support 0
C Laptop Tech Support 7
lucasblack29 Laptop Tech Support 1
W Laptop Tech Support 2
L Laptop Tech Support 0
G Laptop Tech Support 7
newbie_techie Laptop Tech Support 6
TheWalkingDazz Laptop Tech Support 2
P Laptop Tech Support 1
A Laptop Tech Support 6
E Laptop Tech Support 6
D Laptop Tech Support 2
C Laptop Tech Support 1
T Laptop Tech Support 6
E Laptop Tech Support 1
N Laptop Tech Support 2
D Laptop Tech Support 10
S Laptop Tech Support 2

ASK THE COMMUNITY

TRENDING THREADS