Keyboard typing wrong keys, opening programs

Not open for further replies.


Oct 14, 2015
So I have a laptop and randomly, out of the blue, my keyboard messes up.

I was pressing keys and random things would happen like opening email or Word or the calculator, new tabs, or having the wrong letter or letters, type when I press a key.

At first it was keyboard-wide, but then it was isolated to the right side of the keyboard. Now, most of the right side of the keyboard works outside the two bracket keys, the zero key, the colon keys, hyphen, plus, and the quotation keys.

If I press left bracket it will mess with my brightness and usually open a new tab, and sometimes does nothing.. If I press the zero number key, a lot of random characters appear. One example would be 124434 or adbn434 as I continue tapping the button.

The quote button will either turn off WiFi randomly or open the calculator.

It's very strange because my keyboard settings are correct. I tried Control, Shift, and Alt. I tried left Alt, and one other combination. it worked for 3 seconds each time and then it went back to the problem and never worked again, so there's definitely some setting that messed up the keyboard.

I'm hoping someone has an answer.
Last edited by a moderator:

Please do try these troubleshooting steps that may help in resolving this issue:
  1. Again, check the Keyboard settings. Check if the region and language are all set to United States.
  2. Uninstall all Hotkey software (mostly used for games)
  3. Go to Device Manager and look for anything related to Hotkeys.
  4. Do a System Restore and bring it back to a date or time before the issue started happening.
  5. Lastly, try to use either an external keyboard or an on-screen keyboard.
  6. If it works fine with both the on-screen and external keyboards, it's a hardware problem.
Last edited by a moderator:


Jan 6, 2016
I'm sure you've figured this out by now but this happens to me every few months (thanks cat on the keyboard) and 90% of the answers on the front page of google don't help.

I found out that it's some setting in a Windows process called itype and it's presumably activated by some combination of keys pressed at once.

Ctrl-alt-del to go to your task manager and look for itype.exe in the "processes" tab. End process. Voila.
Not open for further replies.
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 2
P Laptop Tech Support 1
C Laptop Tech Support 8
F Laptop Tech Support 4
P Laptop Tech Support 1
N Laptop Tech Support 1
J Laptop Tech Support 4
J Laptop Tech Support 1
P Laptop Tech Support 3
S Laptop Tech Support 1
K Laptop Tech Support 3
M Laptop Tech Support 1
K Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 4
C Laptop Tech Support 1
T Laptop Tech Support 1
V Laptop Tech Support 1
Chakky Laptop Tech Support 1
N Laptop Tech Support 3