Laptop Battery 0% Available (Plugged in, Charging), When Connected to Universal Charger

May 2, 2018
1
0
10
0
I have an ASUS laptop running Windows 8. The original charger wasn't working anymore so I bought a universal charger. I hadn't used the laptop for a week and a half before connecting it to the universal charger. Even though it's already been charging for about 3-4 hours, the battery shows 0% available (plugged in, charging).
It also won't switch on when not connected to the charger.
I tried uninstalling and reinstalling the ACPI and taking out the battery, holding down the power button and putting the battery back in.
 

Bluesh1ft

Commendable
Feb 4, 2017
20
0
1,570
3
Hello. This sounds like the laptop battery has died. This can happen many ways but usually what happens is one or some of the battery cells in the laptop battery pack. And since they're being ran in parallel in a battery pack in order to get longer run time that means that If one or two cells die then the whole battery can't be used anymore because the good cells will attempt to charge the dead cells but they're dead lol

Maybe try looking into buying a new battery for your laptop.
 
Thread starter Similar threads Forum Replies Date
CL19 Laptop Tech Support 1
A Laptop Tech Support 3
A Laptop Tech Support 3
A Laptop Tech Support 1
G Laptop Tech Support 5
P Laptop Tech Support 1
lgdragon040 Laptop Tech Support 1
P Laptop Tech Support 2
R Laptop Tech Support 0
R Laptop Tech Support 0
T Laptop Tech Support 1
G Laptop Tech Support 1
D Laptop Tech Support 1
L Laptop Tech Support 2
V Laptop Tech Support 5
A Laptop Tech Support 1
T Laptop Tech Support 1
A Laptop Tech Support 5
M Laptop Tech Support 2
B Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS