Laptop keyboard and touchpad not working anymore on Acer Aspire E1-771


Nov 4, 2014
Okay, my specs:
Intel i3 3110M
Intel HD Graphics 4000

Okay, I'll describe what excactly happend. One day, all of sudden my laptop's keyboard and touchpad suddenly stopped working. I decided to use a USB mouse to restart the laptop. While restarting the laptop it hangs at the Acer logo, even though I try to restart it, time and time again. So I've found the solution on this website: I had to remove the battery and hold the power button for a few seconds, put the battery back in and then it booted like normal. The thing is that the touchpad didn't work anymore, while the keyboard was okay. The touchpad's driver dissappeared from the "device manager" program. It didn't work even after I installed the driver from the Acer website itself. I then didn't bother with it because I had a USB mouse that I could use.

Okay, present day. I decided to shut down my laptop. When I turned it back on, I couldn't write my password to log in because the keyboard wasn't working! The USB mouse still worked though. I tried to plug a USB keyboard in, but yet it still didn't work. I could only adjust the volume from the USB keyboard with the buttons that were there on the keyboard. So, I unplugged it and tried to type with the laptop's keyboard. Still didn't work, BUT I could however change the brightness and volume with the laptop's keyboard with "fn" and the icons. So I restarted the laptop again to see if it works in the boot menu and guess what, It worked just like normal! I tried doing the old method again that I mentioned earlier above but that didn't work.

Do you guys know any way to fix this problem. I'm using this laptop for school. And I can't figure out how to start in "safe mode" with Windows 8. I'll use the "reinstall windows" method as a last resort because I don't want to lose all my school stuff and projects. Thanks in advance.
PS: I can't log in because I need to write down the password.

Marios Asikis

Apr 27, 2014
I have exactly the same laptop,same problem and did the same with the power button (held it for 60 seconds after i removed battery).I had set a bios password before that and i could not log in too.working keys: `,1,4,5,6,7,8,9,0,-,=,p,[,\,d,k,z,x,c,v,b,n,m,comma key,.
esc,f1-f12,pintscreen,pause,ins,del,tab,caps,Lshift,ctrl,fn,windows key,alt,space bar,alt gr,all arrows,pg up, pg down,explorer menu key.
The only way to fix that is to remove the cable from the MB and place it again.If it doesn't work buy a new keyboard.
note:it is not worth formating the laptop - the problem is not related to software.The problem is the cable connection with the MB.That is why few keys work.
As for the touchpad,update synaptics drivers, this worked for me.
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
F Laptop Tech Support 1
K Laptop Tech Support 1
P Laptop Tech Support 1
T Laptop Tech Support 6
S Laptop Tech Support 1
L Laptop Tech Support 1
H Laptop Tech Support 4
G Laptop Tech Support 1
V Laptop Tech Support 1
U Laptop Tech Support 3
O Laptop Tech Support 6
C Laptop Tech Support 4
D Laptop Tech Support 2
M Laptop Tech Support 4
niftyc Laptop Tech Support 6
K Laptop Tech Support 1
M Laptop Tech Support 14
aakarshan Laptop Tech Support 1
J Laptop Tech Support 1