Lenovo G510 gaming lags while Plugged in

adityvd96

Estimable
May 2, 2015
4
0
4,510
0
I am currently using Lenovo Essential G510 and gaming with graphics AMD Radeon HD 8570m , so the problem is that the games lag when i run them in plugged in state, but when on battery they run perfectly . I have download and updated so many graphic drivers till the present date. The problem still exists.
 
Hi,

Please do try doing a clean install of the graphics card driver.
- Go to Device Manager and uninstall the AMD graphics driver.
- Next is to uninstall anything related to AMD in Programs and Features.
- Once completely uninstalled, download and install the latest driver.
- Here's the link: http://support.amd.com/en-us/download
- Reboot the laptop once the latest driver has been installed.
- After the reboot do test it again and see if the same problem will persist or not.
 

adityvd96

Estimable
May 2, 2015
4
0
4,510
0


I have tried this many times . But the problem still exists ...
 
Thread starter Similar threads Forum Replies Date
V Laptop Tech Support 12
P Laptop Tech Support 1
A Laptop Tech Support 0
9amk Laptop Tech Support 1
L Laptop Tech Support 8
K Laptop Tech Support 0
I Laptop Tech Support 7
S Laptop Tech Support 9
P Laptop Tech Support 7
WD-17 Laptop Tech Support 5
H Laptop Tech Support 2
S Laptop Tech Support 1
A Laptop Tech Support 3
S Laptop Tech Support 1
M Laptop Tech Support 15
J Laptop Tech Support 2
R Laptop Tech Support 3
BryGuySaysHi Laptop Tech Support 3
A Laptop Tech Support 2
L Laptop Tech Support 1

ASK THE COMMUNITY