Lenovo Y50-70 Performance Drop

Status
Not open for further replies.

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0
Hi Guys,

so I have Lenovo Y50-70, like 3-4 month old, mainly using for gaming. All of the sudden the FPS during gaming start dropping rapidly. But after I quit, the slow pace stays, whole system is slow. Iam using cooler pad, temperature during gaming goes a bit above 60, max 70 (dont know if I even saw 70 there, using SpeedFan), when I quit, the temperature goes under 50, max 50. When I go into TaskMannager, CPU is never a problem (like 30-50% max) but the memory and disk usage is. The point is, I cannot figure out what is causing the problem..... I have a suspect it might be a virus/worm... something what is eating the memory and shows up unpredictably.... Antivirus did not find anything (but its Avast free one :/ ) and I dont know how to find a problem in logs.... any advice?

Thanks in advance, I am a big fan of this community, always found answers here!
 
Hi,

First do a clean install of the graphics card driver. Please refer to this link below on how to do the clean install of the graphics driver.
http://www.tomshardware.com/faq/id-2767677/clean-graphics-driver-install-windows.html

Once done do make sure that NVIDIA processor is set to run with your games.
https://nvidia.custhelp.com/app/answers/detail/a_id/2615/kw/setting%20nvidia%20as%20the%20graphics%20card

Next is to run Windows Update as well to run all updates available. And lastly, do run a virus/malware scan just to be sure. Please refer to this link below for tools and guides you can use.
http://www.tomsguide.com/faq/id-1691891/removing-malware-proven-completely-remove-bitcoin-mining-malware.html
 

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0
Thanks for the answer!

But I tried to follow first step, uninstalling the drivers, but Windows (10) keeps updating my display drivers after every reboot. I disabled windows updates thru services, I turned off the hardware automatic updates in System advanced setting, I also used the "Show or hide Updates" troubleshooter by Microsoft to stop Nvidia from updateting (just Nvidia, maybe I should stop everything in the list?) and it keeps updating after reboot. Dead end for me, task for you my friends :(
 

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0


I posted my problem under... thanks a lot
 


Hi there Dadusovic,

If Windows 10 has a native driver, it will always install that upon rebooting the system. If you have the option to automatically download device drivers through Windows update disabled, then it's probably the native/base driver that's being installed (totally normal).

I don't think it's your GPU driver in the first place that's the issue, though.

Have you monitored your task manager when this issue comes up? I've heard of occasional drivers causing memory leaks, as well as malware, but I can't say that's what you have here for sure just yet. Also: what appears to be the rhyme or reason to it (i.e. it only happens while gaming, or it happens sometimes while web browsing/streaming content, etc.)?
 

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0


Hi :)

If I look at task manager (and the game is still on) the game takes all the memory (when the pc runs fine, the games takes "normal" amount of memory) sometimes Iam not evem able to open task manager or to go to explorer. When I ends up the game, memory is still super high, but whem I look at the processes, nothing is taking significant amount of it.... everything looks normal, simply memory is just on the top. There are some Service Host tasks, but they take about 100mb each..... thats why the whole think doesnt make sense to me. I was cleaning PC now from malwares, didnt find anything.... gona try the clean reinstall of drivers, then I have to test it (which mean I have to play games - HURA) and if it will occure, i will post screens of task manager and temperature
 
It really does sound like a bug or some really selective service. Intel faced a memory leak issue awhile back with their iastor.sys service for Intel Matrix Storage manager, or whatever it was called. If you have that service running, you might want to see whether it needs updating or not.

As for malware, try running a couple of complete scans in Safe Mode, with all of your services and startup items disabled ("diagnostic startup"). If you DO have anything hiding, running the scans that may find something (update the anti-malware programs before scanning).
 

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0


After the clean re-install and using all kinds of worm/malware scans I did not face the problem yet again. I think I will mark this topic as solved, but after my exam period I will game much more, if it will occur, I will come back to it.

Thank you very much guys... Love this community!!!!!
 

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0


Hi again, I have to re-open this topic. The problems occurred again guys, but now I notice also that sound stopped working too. SO once again the scenario: being in LoL client, sound stop working (changing playback devices, nothing), entered the game, first 5 min fps 160 (sound nothing) and after, massive drop to fps 15..... Memory on 40% and CPU around 30%.... Game running in backround constantly under 20fps without sound. Sometime the sound stop working by randomly during game, fps drop follows..... sometime the sound stay... fps drops.... If I reinstal all the graphic drivers, it works for a while....and than this. I really dont want to do clean re-install every week.... even thou my updates are still off.....
 

Dadusovic

Estimable
Jan 14, 2016
7
0
4,510
0


Hi again, I have to re-open this topic. The problems occurred again guys, but now I notice also that sound stopped working too. SO once again the scenario: being in LoL client, sound stop working (changing playback devices, nothing), entered the game, first 5 min fps 160 (sound nothing) and after, massive drop to fps 15..... Memory on 40% and CPU around 30%.... Game running in backround constantly under 20fps without sound. Sometime the sound stop working by randomly during game, fps drop follows..... sometime the sound stay... fps drops.... If I reinstal all the graphic drivers, it works for a while....and than this. I really dont want to do clean re-install every week.... even thou my updates are still off.....
 
If a clean install of Windows previously resolved it, then it does not sound like your hardware at fault. Have you manually updated anything recently that may have caused this? Can you use a system restore point to just prior when this started happening again?
 

habibrahal92

Prominent
Jan 30, 2018
1
0
510
0


Hi, I just created an account on the forum to thank you for your help. You have no idea how helpful this was and how many problems it has solved for me since I'm a professional designer and I needed an urgent fix. Thanks a million!
 
Jul 5, 2018
2
0
10
0


 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 6
P Laptop Tech Support 7
E Laptop Tech Support 7
A Laptop Tech Support 2
S Laptop Tech Support 1
R Laptop Tech Support 11
K Laptop Tech Support 4
E Laptop Tech Support 2
A Laptop Tech Support 8
Speed_FreaK Laptop Tech Support 4
P Laptop Tech Support 2
H Laptop Tech Support 2
N Laptop Tech Support 4
A Laptop Tech Support 1
Josh Field Laptop Tech Support 9
A Laptop Tech Support 10
A Laptop Tech Support 1
S Laptop Tech Support 1
D Laptop Tech Support 1
B Laptop Tech Support 4

ASK THE COMMUNITY