LG Plasma 50PJ350

David_Ng

Commendable
Apr 21, 2016
1
0
1,510
0
Had this TV for a few years. Recently it would turn on (red light on in stdby, off in run mode), screen flash then go black. Sound ok. I tested all voltages on power board in Standby and Operating Mode and all was within specfications. I eliminated the X, Y Sustain boards by disconnecting and see if problem went away, no luck. That is same problem with each board removed one at a time. The logic board (one that has the micro processor) or main board seems to be okay because I can do an "autogen" and get the test pattern to come on the screen fine and all in nice vivid color. That only leave me with the control board (inputs). The TV works until Comcast hooked up new line to feed it antenna connection. So, before I spend 120 dollars for a new control board, have anyone seen a Power board gave the correct voltages but yet failed to perform under load? Is there a way to test the control board? I tried different inputs, power is good but same issue. I suspect something in the surface mount chips but this board is very integrated with little discrete components to check. It is expensive since stock is rare to find. I just want to make sure I did not miss anything before purchasing.
 
Thread starter Similar threads Forum Replies Date
A Streaming Video & TVs 2
M Streaming Video & TVs 4
S Streaming Video & TVs 1
R Streaming Video & TVs 1
N Streaming Video & TVs 1
E Streaming Video & TVs 2
L Streaming Video & TVs 1
K Streaming Video & TVs 2
A Streaming Video & TVs 1
E Streaming Video & TVs 1
V Streaming Video & TVs 2
B Streaming Video & TVs 1
A Streaming Video & TVs 2
W Streaming Video & TVs 2
L Streaming Video & TVs 3
D Streaming Video & TVs 2
L Streaming Video & TVs 7
G Streaming Video & TVs 2
B Streaming Video & TVs 1
D Streaming Video & TVs 1

ASK THE COMMUNITY