Mouse and touchpad completely stop working


May 6, 2010
My touchpad and mouse recently just completely stopped working and I can only navigate my computer with keyboard controlls (tab, arrow keys, etc). When I checked the device manager both "HID-Compliant mouse" and "Synaptics PS/2 Port Touchpad" have an error. When I try to update the drivers through device manager it says "Windows found drivers for your device but encountered an error when trying to install them. This device cannot start. (code 10)."

I have tried:
1) Updating drivers via device manager (both auto update and manually choosing drivers).
2) Restarting my computer
3) Uninstalling devices and then restarting computer (they come back after I restart and still broken)
4) Reset Windows 10 via Settings Recovery. This re-installed windows while keeping my person files.

#4 is the only thing that worked, after reinstalling windows 10 I could use my mouse/touchpad again. I thought the problem was solved but not more than 2 days later it came back and I had to do this whole process again. It's super annoying and I don't know what the problem is. I'v been troubleshooting for a couple days now and I have to wait a couple more weeks until I get paid to bring my computer in to a technician which I doubt will be very helpful in china.

The first time it happened I remember my mouse just started working very poorly while playing a game. So I looked into the problem and discovered the driver issue with HID-Compliant mouse and Synaptics ps/2 port touchpad (at the time I could still use my mouse but it occassionally moved very poorly in game and caused ingame lag). I restarted my computer to see if that would fix it but after restarting i couldn't use the mouse/touchpad at all. Second time it happened I was updating some drivers since I had just recently reinstalled the OS and I noticed those 2 drivers had errors again! I could still use the mouse/touchpad but the next laptop restart caused them to stop working entirely. Now i'v reinstalled the OS again and i'm trying to find a solution if it happens again (besides reinstalling OS).


Hasee K670D-i7

GTX 870M 3GB
Intel Core i7-4710MQ
16GB ddr3 ram
Windows 10 (creators update)
Mouse - Razer Naga (the mouse still lights up and I can use the numberpad on the mouse but the mouse doesn't move at all on computer, after OS reinstall can use no problem)


Sep 3, 2013

i suggest going to the manufacturer site to actually download the proper driver.using windows updater will only mess things up as.the same goes to 3rd party software like driver booster and easy driver which is never recommended for installing its best if you go to the manufacturer site to see the drivers listed for your notebook.


May 6, 2010

Well the laptop had no operating system when I bought it and I installed a copy of windows 7 which the store sold me which turned out to be fake (common event living in china). So I bought a copy of windows 10 from the windows store and am using that.

I only tried to update through device manager and windows updater (updater didn't have anything new). I also use both driver booster 4 and easy driver to search out of date drivers. I'll try to see if I can find and download a copy of the drivers for the future.

But i'm wondering if it's actually an issue with the drivers bc it failed to do the installation because "device failed to start (code 10)". But at the same time could it even be a hardware error if a fresh reinstall fixes it?
Thread starter Similar threads Forum Replies Date
V Laptop Tech Support 0
F Laptop Tech Support 4
M Laptop Tech Support 5
A Laptop Tech Support 1
M Laptop Tech Support 3
J Laptop Tech Support 1
B Laptop Tech Support 1
N Laptop Tech Support 1
W Laptop Tech Support 6
G Laptop Tech Support 2
deepakhkadam Laptop Tech Support 1
M Laptop Tech Support 1
L Laptop Tech Support 1
M Laptop Tech Support 2
X Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 3
N Laptop Tech Support 2
R Laptop Tech Support 1
J Laptop Tech Support 1