MSI Live Update not working ?

Halfsqot

Estimable
Nov 19, 2015
1
0
4,510
0
I went onto Live update and saw that i had a few utilitys that i could download but when i downloaded them it seemed fine but when i scanned again for newer drivers the same drivers i just installed showed up again ? here are the screenshots of the 'Live Update' and 'History' http://imgur.com/a/mB9iG alot of people are stating this breaks your mobo! This is a new pc and i would hate that to happen :( can anyone give me some reassurance that it is perfectly fine. Thanks !
 

Phillip Corcoran

Splendid
Moderator
You may have simply installed drivers which were already installed and up to date, they look pretty recent to me.
What do you expect, new drivers to be released for your board every week? It aint gonna happen.

Old drivers (or even new ones) can break your motherboard? - - how does that work then?
I never heard anything so ridiculous.
 

Phillip Corcoran

Splendid
Moderator
You may have simply installed drivers which were already installed and up to date, they look pretty recent to me.
What do you expect, new drivers to be released for your board every week? It aint gonna happen.

Old drivers (or even new ones) can break your motherboard? - - how does that work then?
I never heard anything so ridiculous.
 
Thread starter Similar threads Forum Replies Date
L Apps General Discussion 0
P Apps General Discussion 1
A Apps General Discussion 3
R Apps General Discussion 9
G Apps General Discussion 2
S Apps General Discussion 2
R Apps General Discussion 5
P Apps General Discussion 1
P Apps General Discussion 1
G Apps General Discussion 2
B Apps General Discussion 8
V Apps General Discussion 1
N Apps General Discussion 3
S Apps General Discussion 4
D Apps General Discussion 1
S Apps General Discussion 1
A Apps General Discussion 1
B Apps General Discussion 4
X Apps General Discussion 1
J Apps General Discussion 37

ASK THE COMMUNITY